summaryrefslogtreecommitdiff
path: root/daemon/meson.build
diff options
context:
space:
mode:
authorIñigo Martínez <inigomartinez@gmail.com>2017-10-31 12:35:34 +0100
committerOndrej Holy <oholy@redhat.com>2017-10-31 18:24:59 +0100
commit5e2dff62c1ec332f3f8d7c0c1438835dc66a56b0 (patch)
tree1c84ef818471adb6a9ffab870c38c92400621a71 /daemon/meson.build
parentd43a3b9ddb5cb1409613788934b82e23514383f9 (diff)
downloadgvfs-5e2dff62c1ec332f3f8d7c0c1438835dc66a56b0.tar.gz
build: Improve installation on system paths
Instead of being hardcoded, D-Bus, systemd and GIO modules paths can be checked by using the information in their correspondant pkg-config files. This patch uses the information on pkg-config files by default, and also allows the user to provide this information to avoid overwriting system files. https://bugzilla.gnome.org/show_bug.cgi?id=786149
Diffstat (limited to 'daemon/meson.build')
-rw-r--r--daemon/meson.build6
1 files changed, 3 insertions, 3 deletions
diff --git a/daemon/meson.build b/daemon/meson.build
index d483a0af..606d83f4 100644
--- a/daemon/meson.build
+++ b/daemon/meson.build
@@ -7,18 +7,18 @@ daemon_service = configure_file(
input: service + '.in',
output: service,
install: true,
- install_dir: gvfs_dbus_service_dir,
+ install_dir: dbus_service_dir,
configuration: service_conf
)
-if have_systemd_user_unit
+if install_systemd_user_unit_dir
service = 'gvfs-daemon.service'
configure_file(
input: service + '.in',
output: service,
install: true,
- install_dir: systemd_user_dir,
+ install_dir: systemd_user_unit_dir,
configuration: service_conf
)
endif