summaryrefslogtreecommitdiff
path: root/daemon/meson.build
diff options
context:
space:
mode:
authorIñigo Martínez <inigomartinez@gmail.com>2018-12-17 16:19:19 +0100
committerIñigo Martínez <inigomartinez@gmail.com>2019-01-04 16:33:53 +0100
commit9523d8e09e0088c8cd58ace494d47cc3083151fc (patch)
tree489b34243b97c821fc4541dcbf60b6b460c45219 /daemon/meson.build
parent5bc63310a721946199c68160b5134971d5fe0fc6 (diff)
downloadgvfs-9523d8e09e0088c8cd58ace494d47cc3083151fc.tar.gz
build: Use / instead of join_paths
Since meson 0.49, the `/` character can be used to join paths[0], so all the instances of `join_paths` have been replaced. [0] http://mesonbuild.com/Release-notes-for-0-49-0.html#joining-paths-with-
Diffstat (limited to 'daemon/meson.build')
-rw-r--r--daemon/meson.build8
1 files changed, 4 insertions, 4 deletions
diff --git a/daemon/meson.build b/daemon/meson.build
index b835acf6..4f3155ef 100644
--- a/daemon/meson.build
+++ b/daemon/meson.build
@@ -21,7 +21,7 @@ endif
dbus_service_conf = configuration_data()
dbus_service_conf.set('service', dbus_service)
-dbus_service_conf.set('exec', join_paths(gvfs_libexecdir, dbus_exec))
+dbus_service_conf.set('exec', gvfs_libexecdir / dbus_exec)
dbus_service_conf.set('systemd_service', dbus_systemd_service)
daemon_service = configure_file(
@@ -396,12 +396,12 @@ if enable_admin
output: policy,
po_dir: po_dir,
install: true,
- install_dir: join_paths(gvfs_datadir, 'polkit-1', 'actions'),
+ install_dir: gvfs_datadir / 'polkit-1/actions',
)
install_data(
gvfs_namespace + '.file-operations.rules',
- install_dir: join_paths(gvfs_datadir, 'polkit-1', 'rules.d'),
+ install_dir: gvfs_datadir / 'polkit-1/rules.d',
)
endif
@@ -635,5 +635,5 @@ install_data(
install_data(
convert_data,
- install_dir: join_paths(gvfs_datadir, 'GConf', 'gsettings'),
+ install_dir: gvfs_datadir / 'GConf/gsettings',
)