summaryrefslogtreecommitdiff
path: root/daemon/meson.build
diff options
context:
space:
mode:
authorIñigo Martínez <inigomartinez@gmail.com>2018-12-17 21:48:02 +0100
committerIñigo Martínez <inigomartinez@gmail.com>2019-01-04 16:33:53 +0100
commitdc34f1be6a3c1fa6d5615ad5d647003e7ce3196f (patch)
tree46017945914ab9e69467f12a69bb5ee7180ef07d /daemon/meson.build
parent12f4c5a98e1b4a1a0b5fba45439dab74d12519bb (diff)
downloadgvfs-dc34f1be6a3c1fa6d5615ad5d647003e7ce3196f.tar.gz
build: Use generators placeholders
Functions derived from generators as `configure_file`, `custom_target` and `i18n.merge_file` can use placeholders like `@BASENAME@` that removes the extension from the input filename string. The output string has been replaced by this placeholder that allows in some cases the use of less variables.
Diffstat (limited to 'daemon/meson.build')
-rw-r--r--daemon/meson.build12
1 files changed, 5 insertions, 7 deletions
diff --git a/daemon/meson.build b/daemon/meson.build
index a219fc13..e803a743 100644
--- a/daemon/meson.build
+++ b/daemon/meson.build
@@ -10,7 +10,7 @@ if install_systemd_systemduserunitdir
configure_file(
input: service + '.in',
- output: service,
+ output: '@BASENAME@',
configuration: service_conf,
install: true,
install_dir: systemd_systemduserunitdir,
@@ -386,14 +386,14 @@ if enable_admin
policy_in = configure_file(
input: policy + '.in.in',
- output: policy + '.in',
+ output: '@BASENAME@',
configuration: service_conf,
)
i18n.merge_file(
policy,
input: policy_in,
- output: policy,
+ output: '@BASENAME@',
po_dir: po_dir,
install: true,
install_dir: gvfs_datadir / 'polkit-1/actions',
@@ -599,11 +599,9 @@ foreach program: programs
endforeach
foreach mount: mounts
- name = mount + '.mount'
-
configure_file(
- input: name + '.in',
- output: name,
+ input: mount + '.mount.in',
+ output: '@BASENAME@',
configuration: service_conf,
install: true,
install_dir: gvfs_mountdir,