summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2020-06-16 13:28:35 +0200
committerBastien Nocera <hadess@hadess.net>2020-06-16 14:20:08 +0200
commit13551f3f40d41f1357126ac5a26d0fa012cd8123 (patch)
treea294eb9c61cb4dc9f6ecb6935537803ea6cd10e4 /meson.build
parentc24e16e8697f62d365659310798e4bf13a1d03f9 (diff)
downloadgvfs-13551f3f40d41f1357126ac5a26d0fa012cd8123.tar.gz
afc: Add support for libplist-2.2
Which changed name from libplist to libplist-2.0 to embed its API version number in the library name.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 1750f65c..187bfd55 100644
--- a/meson.build
+++ b/meson.build
@@ -357,7 +357,10 @@ config_h.set('HAVE_LOGIND', enable_logind)
enable_afc = get_option('afc')
if enable_afc
libimobiledevice_dep = dependency('libimobiledevice-1.0', version: '>= 1.2')
- libplist_dep = dependency('libplist', version: '>= 0.15')
+ libplist_dep = dependency('libplist-2.0', required: false)
+ if not libplist_dep.found()
+ libplist_dep = dependency('libplist', version: '>= 0.15')
+ endif
endif
# *** Check if we should build with GOA volume monitor ***