summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorOndrej Holy <oholy@redhat.com>2021-05-12 10:19:56 +0200
committerOndrej Holy <oholy@redhat.com>2021-06-07 07:28:17 +0000
commit141eee12c5c6c37e098cef2f1a80d1df58168d5b (patch)
tree1dc3fdeedb85fad3fc12b85255c5bf7db6c06526 /meson.build
parentdede4bbda08a02c47b917c03eaf59e994b15edbb (diff)
downloadgvfs-141eee12c5c6c37e098cef2f1a80d1df58168d5b.tar.gz
admin: Make the privileged group configurable
Currently, `wheel` group is hardcoded in the `.rules` file which is there to prevent redundant password prompt when starting gvfsd-admin. The Debian based systems obviously uses `sudo` group instead of `wheel`. Let's make the privileged group configurable. https://gitlab.gnome.org/GNOME/gvfs/-/issues/565
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index b881ebe3..4e5e021b 100644
--- a/meson.build
+++ b/meson.build
@@ -299,6 +299,7 @@ endif
config_h.set('HAVE_GCR', enable_gcr)
# *** Check if we should build with admin backend ***
+privileged_group = get_option('privileged_group')
enable_admin = get_option('admin')
if enable_admin
libcap_dep = dependency('libcap')
@@ -493,7 +494,8 @@ meson.add_install_script(
summary({
'systemduserunitdir': systemd_systemduserunitdir,
'tmpfilesdir': systemd_tmpfilesdir,
-}, section: 'Directories')
+ 'privileged_group': privileged_group,
+}, section: 'Configuration')
summary({
'admin': enable_admin,