summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNiveditha Rau <niveditha.rau@oracle.com>2020-02-06 20:11:21 -0800
committerOndrej Holy <oholy@redhat.com>2020-02-11 16:48:01 +0000
commit6531d3f7359ca8034c6a2b40a0087fe605e0cd8f (patch)
treef9d45051aba1e92e839544db4450f3a35f91c270 /meson.build
parent17b7e2b63dcfb75f38b5bc045bf7671379ab525a (diff)
downloadgvfs-6531d3f7359ca8034c6a2b40a0087fe605e0cd8f.tar.gz
build: Fix login_tty detection on systems without libutil
login_tty function is available on Solaris, but libutil isn't there. Let's update the code to make the detection work also if libutil is not available.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 1 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index b5862d3a..1a4995b8 100644
--- a/meson.build
+++ b/meson.build
@@ -84,8 +84,7 @@ have_openpty = cc.has_function('openpty', dependencies: util_dep)
config_h.set('HAVE_OPENPTY', have_openpty,
description: 'Define if you have the openpty function.')
-config_h.set('HAVE_LOGIN_TTY', util_dep.found() and cc.has_function('login_tty', dependencies: util_dep),
- description: 'Whether login_tty is available')
+config_h.set('HAVE_LOGIN_TTY', cc.has_function('login_tty', dependencies: util_dep), description: 'Whether login_tty is available')
# headers
check_headers = [