summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMayank Sharma <mayank8019@gmail.com>2019-08-28 12:25:54 +0530
committerOndrej Holy <oholy@redhat.com>2020-01-31 06:54:02 +0000
commit8b47b09a5adf35ee52d5a1e5f52fb5a6597b2598 (patch)
tree813d386ceae9467bd50e4950c2168ffc51d4ede3 /meson.build
parentcaf866440e0fb2a7a0e4b105c8a5b8c1e7875654 (diff)
downloadgvfs-8b47b09a5adf35ee52d5a1e5f52fb5a6597b2598.tar.gz
build: Bump libgdata dependency to support latest features
libgdata API has been augmented with GDataDocumentsProperty API in the latest release 0.17.11. Since, we're using that API to support copy/move operations, we bump the required dependency version accordingly. We also remove the HAVE_LIBGDATA_* ifdefs since we require libgdata version >= 0.17.11 for the google backend to work properly.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 1 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 62256295..8fcfee7f 100644
--- a/meson.build
+++ b/meson.build
@@ -417,10 +417,7 @@ enable_google = get_option('google')
if enable_google
assert(enable_goa, 'Google backend requested but GOA is required')
- libgdata_dep = dependency('libgdata', version: '>= 0.17.3')
- foreach version: ['0.17.7', '0.17.9']
- config_h.set10('HAVE_LIBGDATA_' + version.underscorify(), libgdata_dep.version().version_compare('>= ' + version))
- endforeach
+ libgdata_dep = dependency('libgdata', version: '>= 0.17.11')
endif
# *** Check for gphoto2 ***