summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorOndrej Holy <oholy@redhat.com>2019-01-07 17:44:10 +0100
committerOndrej Holy <oholy@redhat.com>2019-01-07 17:44:10 +0100
commitab6723ff454675abe7fad31945b2aebeac5b1e6a (patch)
tree489b34243b97c821fc4541dcbf60b6b460c45219 /meson.build
parent057122b2c375ec5ad8a5e4a3497bfbd7b817acf0 (diff)
downloadgvfs-ab6723ff454675abe7fad31945b2aebeac5b1e6a.tar.gz
Revert "build: Fix the use of pkg-config file variables"
This reverts commit 22e9f7721b891b17cd726f1bf92b15a35be34d22.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build48
1 files changed, 19 insertions, 29 deletions
diff --git a/meson.build b/meson.build
index 19e91c3a..c6ee6fe3 100644
--- a/meson.build
+++ b/meson.build
@@ -24,6 +24,7 @@ gvfs_rpath = gvfs_pkglibdir
gvfs_remote_volume_monitors_dir = gvfs_pkgdatadir / 'remote-volume-monitors'
gvfs_mountdir = gvfs_pkgdatadir / 'mounts'
+gvfs_schema_dir = gvfs_datadir / 'glib-2.0/schemas'
gvfs_namespace = 'org.gtk.vfs'
@@ -238,44 +239,33 @@ endif
config_h.set('HAVE_GCRYPT', enable_gcrypt)
# *** Check for dbus service dir ***
-dbus_session_bus_services_dir = dependency('dbus-1').get_pkgconfig_variable(
- 'session_bus_services_dir',
- define_variable: ['datadir', gvfs_datadir],
-)
+dbus_dep = dependency('dbus-1')
+dbus_service_dir = dbus_dep.get_pkgconfig_variable('session_bus_services_dir', define_variable: ['datadir', gvfs_datadir])
dbus_service_in = files('dbus.service.in')
-# *** Check for giomoduledir and schemasdir ***
-gio_giomoduledir = gio_dep.get_pkgconfig_variable(
- 'giomoduledir',
- define_variable: ['libdir', gvfs_libdir],
-)
-
-gio_schemasdir = gio_dep.get_pkgconfig_variable(
- 'schemasdir',
- define_variable: ['datadir', gvfs_datadir],
- default: gvfs_datadir / 'glib-2.0/schemas',
-)
+# *** Check for gio module dir ***
+gio_module_dir = gio_dep.get_pkgconfig_variable('giomoduledir', define_variable: ['libdir', gvfs_libdir])
# *** Check for systemd options ***
-systemd_systemduserunitdir = get_option('systemduserunitdir')
-install_systemd_systemduserunitdir = (systemd_systemduserunitdir != 'no')
+systemd_user_unit_dir = get_option('systemduserunitdir')
+install_systemd_user_unit_dir = (systemd_user_unit_dir != 'no')
-systemd_tmpfilesdir = get_option('tmpfilesdir')
-install_systemd_tmpfilesdir = (systemd_tmpfilesdir != 'no')
+tmp_files_dir = get_option('tmpfilesdir')
+install_tmp_files_dir = (tmp_files_dir != 'no')
-if install_systemd_systemduserunitdir or install_systemd_tmpfilesdir
- if systemd_systemduserunitdir == '' or systemd_tmpfilesdir == ''
+if install_systemd_user_unit_dir or install_tmp_files_dir
+ if systemd_user_unit_dir == '' or tmp_files_dir == ''
systemd_dep = dependency('systemd', version: '>= 206', required: false)
- if install_systemd_systemduserunitdir and systemd_systemduserunitdir == ''
+ if install_systemd_user_unit_dir and systemd_user_unit_dir == ''
assert(systemd_dep.found(), 'systemd required but not found, please provide a valid systemd user unit dir or disable it')
- systemd_systemduserunitdir = systemd_dep.get_pkgconfig_variable('systemduserunitdir')
+ systemd_user_unit_dir = systemd_dep.get_pkgconfig_variable('systemduserunitdir')
endif
- if install_systemd_tmpfilesdir and systemd_tmpfilesdir == ''
+ if install_tmp_files_dir and tmp_files_dir == ''
assert(systemd_dep.found(), 'systemd not found, if you use opentmpfiles please provide a valid systemd user unit dir or disable it')
- systemd_tmpfilesdir = systemd_dep.get_pkgconfig_variable('tmpfilesdir')
+ tmp_files_dir = systemd_dep.get_pkgconfig_variable('tmpfilesdir')
endif
endif
endif
@@ -491,14 +481,14 @@ configure_file(
meson.add_install_script(
'meson_post_install.py',
- gio_schemasdir,
- gio_giomoduledir,
+ gvfs_schema_dir,
+ gio_module_dir,
)
output = gvfs_name + ' ' + gvfs_version + ' configuration summary:\n'
output += '\n'
-output += ' systemduserunitdir: ' + systemd_systemduserunitdir + '\n'
-output += ' tmpfilesdir: ' + systemd_tmpfilesdir + '\n'
+output += ' systemduserunitdir: ' + systemd_user_unit_dir + '\n'
+output += ' tmpfilesdir: ' + tmp_files_dir + '\n'
output += '\n'
output += ' admin: ' + enable_admin.to_string() + '\n'
output += ' afc: ' + enable_afc.to_string() + '\n'