summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDaniel Kolesa <dkolesa@igalia.com>2021-02-11 22:43:53 +0100
committerDaniel Kolesa <dkolesa@igalia.com>2022-02-01 20:55:46 +0100
commitbeaaf78b72640f8231f49fdfc1b6dcfc3d14f149 (patch)
tree0fbfd0f22d48fac0cd68e4e76cf00f0e99d9f978 /meson.build
parent2cadf5d4864f2df7e999b634070bffa8590d4f26 (diff)
downloadgvfs-beaaf78b72640f8231f49fdfc1b6dcfc3d14f149.tar.gz
dav, http: port to libsoup3
The dav and http backends of the daemon now use libsoup3. Things should work more or less the same as before. One caveat is that the soup session no longer defaults to ssl-strict, so it will no longer silently accept certificates. This does not affect the DAV backend (it has its own handling which is replicated in the soup3 port) but it does affect the http backend. Fixes: https://gitlab.gnome.org/GNOME/gvfs/-/issues/208
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 557eef83..9b771ffa 100644
--- a/meson.build
+++ b/meson.build
@@ -310,7 +310,7 @@ endif
enable_http = get_option('http')
if enable_http
assert(have_libxml, 'http required but libxml-2.0 not found')
- libsoup_dep = dependency('libsoup-2.4', version: '>= 2.58.0')
+ libsoup_dep = dependency('libsoup-3.0', version: '>= 3.0.0')
endif
# *** Check if we should build with DNS-SD backend ***