summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorOndrej Holy <oholy@redhat.com>2019-01-07 17:44:09 +0100
committerOndrej Holy <oholy@redhat.com>2019-01-07 17:44:09 +0100
commitd1974938a5acaaed2cfee8da6dc254c74c0d4fb6 (patch)
treea6c940107753ad623c3b9bc08b864bd89194d7ce /meson.build
parent2b0a4051fba0207b78ce764d4a2faccaf7e889e4 (diff)
downloadgvfs-d1974938a5acaaed2cfee8da6dc254c74c0d4fb6.tar.gz
Revert "build: Define meson information early"
This reverts commit 28dfdbf9c759a4681c6b43b179079cba09e571b4.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build22
1 files changed, 11 insertions, 11 deletions
diff --git a/meson.build b/meson.build
index d5916082..d224cdee 100644
--- a/meson.build
+++ b/meson.build
@@ -29,17 +29,6 @@ gvfs_namespace = 'org.gtk.vfs'
gvfs_debug = get_option('buildtype').contains('debug')
-gnome = import('gnome')
-i18n = import('i18n')
-pkg = import('pkgconfig')
-
-po_dir = meson.current_source_dir() / 'po'
-
-top_inc = include_directories('.')
-
-service_conf = configuration_data()
-service_conf.set('libexecdir', gvfs_prefix / gvfs_libexecdir)
-
cc = meson.get_compiler('c')
config_h = configuration_data()
@@ -464,6 +453,17 @@ endif
enable_devel_utils = get_option('devel_utils')
enable_installed_tests = get_option('installed_tests')
+gnome = import('gnome')
+i18n = import('i18n')
+pkg = import('pkgconfig')
+
+service_conf = configuration_data()
+service_conf.set('libexecdir', gvfs_prefix / gvfs_libexecdir)
+
+po_dir = meson.source_root() / 'po'
+
+top_inc = include_directories('.')
+
subdir('common')
subdir('metadata')
subdir('client')