summaryrefslogtreecommitdiff
path: root/monitor/meson.build
diff options
context:
space:
mode:
authorIñigo Martínez <inigomartinez@gmail.com>2018-12-17 21:08:43 +0100
committerIñigo Martínez <inigomartinez@gmail.com>2019-01-21 21:18:06 +0100
commitbced2bd5c383935c1487e0d72800c6439e5859c8 (patch)
tree663e79305c7bdbf0ef8895d6afb4a19266b0ea3d /monitor/meson.build
parentce13717c433c841f7b3e749ccedcdfc830c4f761 (diff)
downloadgvfs-bced2bd5c383935c1487e0d72800c6439e5859c8.tar.gz
build: Fix the use of pkg-config file variables
The names of the variables in meson corresponding to the variables obtained from the pkg-config files has been fixed by using a pattern. The pattern uses the dependency name as the prefix and the obtained variable as the suffix.
Diffstat (limited to 'monitor/meson.build')
-rw-r--r--monitor/meson.build6
1 files changed, 3 insertions, 3 deletions
diff --git a/monitor/meson.build b/monitor/meson.build
index 05a080e7..e32817ad 100644
--- a/monitor/meson.build
+++ b/monitor/meson.build
@@ -31,14 +31,14 @@ foreach monitor: monitors
dbus_exec = 'gvfs-@0@-volume-monitor'.format(monitor_name)
dbus_systemd_service = ''
- if install_systemd_user_unit_dir
+ if install_systemd_systemduserunitdir
service = dbus_exec + '.service'
configure_file(
input: monitor_name / service + '.in',
output: service,
install: true,
- install_dir: systemd_user_unit_dir,
+ install_dir: systemd_systemduserunitdir,
configuration: service_conf,
)
@@ -61,7 +61,7 @@ foreach monitor: monitors
input: dbus_service_in,
output: dbus_service + '.service',
install: true,
- install_dir: dbus_service_dir,
+ install_dir: dbus_session_bus_services_dir,
configuration: dbus_service_conf,
)