summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
new file mode 100644
index 0000000..9de622d
--- /dev/null
+++ b/lib/Makefile.am
@@ -0,0 +1,42 @@
+# Make gzip/lib -*-Makefile-*-
+
+# Copyright (C) 2006, 2009-2016 Free Software Foundation, Inc.
+
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or
+# (at your option) any later version.
+
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+AM_CFLAGS =
+BUILT_SOURCES =
+CLEANFILES =
+EXTRA_DIST =
+MOSTLYCLEANDIRS =
+MOSTLYCLEANFILES =
+SUFFIXES =
+noinst_LIBRARIES =
+
+include gnulib.mk
+
+libgzip_a_LIBADD += $(LIBOBJS)
+libgzip_a_DEPENDENCIES += $(LIBOBJS)
+AM_CFLAGS += $(GNULIB_WARN_CFLAGS) $(WERROR_CFLAGS)
+
+match.$(OBJEXT): match.c
+ $(AM_V_GEN)cp $(srcdir)/match.c _match.S
+ $(AM_V_at)$(CPP) $(CPPFLAGS) $(ASCPPFLAGS) _match.S > _match.i
+ $(AM_V_at)$(ASCPPPOST) < _match.i > match_.s
+ $(AM_V_at)$(CC) $(CPPFLAGS) $(CFLAGS) $(ASFLAGS_config) -c match_.s
+ $(AM_V_at)mv match_.$(OBJEXT) $@
+ $(AM_V_at)rm -f _match.S _match.i match_.s
+
+MOSTLYCLEANFILES += _match.S _match.i match_.s