summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2021-12-01 13:46:36 -0800
committerPaul Eggert <eggert@cs.ucla.edu>2021-12-01 15:38:58 -0800
commit1440bdbd16cc40f3ef3d0d91106373e29611f528 (patch)
tree4d1145893f5bad7531e3f966a0ba5e5dc17656a0 /Makefile.am
parent4ed9954c67194f79dbbbdb8f96da4d31c4bcba09 (diff)
downloadgzip-1440bdbd16cc40f3ef3d0d91106373e29611f528.tar.gz
maint: reduce module coupling
If a symbol is extern but never used by another module, make it static instead, or remove it if it is not used anywhere. * Makefile.am (gzip_SOURCES): Remove lzw.c. * bits.c (bi_buf, bi_valid) [!IBM_Z_DFLTCC]: * deflate.c (prev_length, match_start, max_chain_length) (good_match, lm_init): * gzip.c (verbose) [!DEBUG]: * unlzw.c (block_mode): Now static. * gzip.c (help, main, do_lzw): * revision.h: Simplify by assuming !LZW. * util.c (setcrc): Define only if IBM_Z_DFLTCC. (make_simple_name): Define only if NO_MULTIPLE_DOTS.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index cd79331..f5221ca 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -51,7 +51,7 @@ bin_PROGRAMS = gzip
bin_SCRIPTS = gunzip gzexe zcat zcmp zdiff \
zegrep zfgrep zforce zgrep zless zmore znew
gzip_SOURCES = \
- bits.c deflate.c gzip.c inflate.c lzw.c \
+ bits.c deflate.c gzip.c inflate.c \
trees.c unlzh.c unlzw.c unpack.c unzip.c util.c zip.c
gzip_LDADD = libver.a lib/libgzip.a
gzip_LDADD += $(LIB_CLOCK_GETTIME)