summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2010-02-01 15:02:34 +0100
committerJim Meyering <meyering@redhat.com>2010-02-03 06:23:57 +0100
commit27a6b364d709c72a3f9d1641d68c985baa44e7b3 (patch)
tree3a647ce981d79fda82454d3621a79b4705798115 /Makefile.am
parent64b0a3b0606a365550add169417985a2cb4d70f0 (diff)
downloadgzip-27a6b364d709c72a3f9d1641d68c985baa44e7b3.tar.gz
tests: move the hufts-segv test to its own file
* tests/hufts: New test. * Makefile.am (TESTS): Add tests/ (check-local): Remove the hufts-segv test from this rule.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 181899a..b4e75fc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -97,12 +97,11 @@ check-local: $(FILES_TO_CHECK) $(bin_PROGRAMS) gzip.doc.gz
for file in $(FILES_TO_CHECK); do \
./gzip -cv -- "$$file" | ./gzip -d | cmp - "$$file" || exit 1; \
done
- ./gzip -dc $(srcdir)/tests/hufts-segv.gz > /dev/null 2>&1; \
- test $$? = 1
@echo 'Test succeeded.'
TESTS = \
tests/helin-segv \
+ tests/hufts \
tests/memcpy-abuse \
tests/stdin \
tests/trailing-nul \