summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2012-10-20 23:15:26 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2012-10-20 23:16:05 -0700
commit60b3f4eb672a85de28ecaad47ed426f8c8fe6c32 (patch)
tree37e061073445afdd8c24e54c93615e69371c2bbb /Makefile.am
parent953e93ec52c660d5c3ef91f8ab463aa1be965b38 (diff)
downloadgzip-60b3f4eb672a85de28ecaad47ed426f8c8fe6c32.tar.gz
zgrep: do not assume standard 'grep' has -e
On Solaris 11, /usr/bin/grep -e does not work. Problem reported by Petr Sumbera in <http://lists.gnu.org/archive/html/bug-gzip/2012-10/msg00003.html>. * Makefile.am (.in): Substitute @GREP@. * configure.ac (AC_PROG_GREP): Invoke. * zgrep.in (grep): Use @GREP@.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 86a0297..90fff2d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -84,6 +84,7 @@ SUFFIXES = .in
$(AM_V_GEN)sed \
-e 's|/bin/sh|$(SHELL)|g' \
-e 's|[@]bindir@|'\''$(bindir)'\''|g' \
+ -e 's|[@]GREP@|$(GREP)|g' \
-e 's|[@]VERSION@|$(VERSION)|g' \
$(srcdir)/$@.in >$@-t \
&& chmod a+x $@-t \