summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRusty Russell <rusty@rustcorp.com.au>2015-09-05 12:08:28 -0700
committerJim Meyering <meyering@fb.com>2016-03-02 08:58:14 -0800
commitd6d48f427b4839352437be9688142f6733028d22 (patch)
treee8a5def9fa5a46898536bbfe61c430eeea39f93f /Makefile.am
parent9860eb784749f8588346850e693d7460e5be1601 (diff)
downloadgzip-d6d48f427b4839352437be9688142f6733028d22.tar.gz
gzip: support the --rsyncable option
* deflate.c: Include verify.h. (RSYNC_WIN, RSYNC_SUM_MATCH): Define. (rsync_sum, rsync_chunk_end): Declare file-scoped globals. (lm_init): Initialize globals. (fill_window): Update rsync_chunk_end. (rsync_roll): New function. (RSYNC_ROLL): New macro. (FLUSH_BLOCK): Update for new "pad" parameter. (deflate_fast): Use RSYNC_ROLL and flush/pad. (deflate): Likewise. * trees.c (flush_block): Add "pad" parameter. * gzip.c (rsync): New global. (RSYNCABLE_OPTION, longopts, help): Add the option. (main): Set the new global. * gzip.h (rsync): Declare new global. (flush_block): Update prototype. * doc/gzip.texi: Document it. * gzip.1: Likewise. * bootstrap.conf: Use verify module. * NEWS (New feature): Mention it. * Makefile.am (check-local): Add tests and use AM_V__* command- hiding opions. Reported against Debian here: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=118118
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 12 insertions, 9 deletions
diff --git a/Makefile.am b/Makefile.am
index 9d06d98..b01ddee 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -108,16 +108,19 @@ gen-ChangeLog:
FILES_TO_CHECK = $(bin_SCRIPTS) \
$(top_srcdir)/ChangeLog $(top_srcdir)/configure $(top_srcdir)/gzip.c
check-local: $(FILES_TO_CHECK) $(bin_PROGRAMS) gzip.doc.gz
- { test '$(srcdir)' != . || ./zdiff --__bindir . -c gzip.doc.gz; }
- ./zdiff --__bindir . -c $(srcdir)/gzip.doc $(srcdir)/gzip.doc
- ./zdiff --__bindir . $(srcdir)/gzip.doc gzip.doc.gz
- ./zdiff --__bindir . -c - $(srcdir)/gzip.doc <gzip.doc.gz
- ./zdiff --__bindir . -c gzip.doc.gz gzip.doc.gz
- ./zgrep --__bindir . -iV >/dev/null
- for file in $(FILES_TO_CHECK); do \
- ./gzip -cv -- "$$file" | ./gzip -d | cmp - "$$file" || exit 1; \
+ $(AM_V_GEN){ test '$(srcdir)' != . \
+ || ./zdiff --__bindir . -c gzip.doc.gz; }
+ $(AM_V_at)./zdiff --__bindir . -c $(srcdir)/gzip.doc $(srcdir)/gzip.doc
+ $(AM_V_at)./zdiff --__bindir . $(srcdir)/gzip.doc gzip.doc.gz
+ $(AM_V_at)./zdiff --__bindir . -c - $(srcdir)/gzip.doc <gzip.doc.gz
+ $(AM_V_at)./zdiff --__bindir . -c gzip.doc.gz gzip.doc.gz
+ $(AM_V_at)./zgrep --__bindir . -iV >/dev/null
+ $(AM_V_at)for opt in --rsyncable '' -1 -9; do \
+ for file in $(FILES_TO_CHECK); do \
+ ./gzip $$opt -c -- "$$file" \
+ | ./gzip -d | cmp - "$$file" || exit 1; \
+ done; \
done
- @echo 'Test succeeded.'
install-exec-hook: remove-installed-links
install-exec-hook remove-installed-links: