summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 4f51b61..da2fda8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -62,7 +62,9 @@ gzip_SOURCES = \
bits.c deflate.c gzip.c inflate.c \
trees.c unlzh.c unlzw.c unpack.c unzip.c util.c zip.c
gzip_LDADD = libver.a lib/libgzip.a
-gzip_LDADD += $(LIB_CLOCK_GETTIME)
+gzip_LDADD += $(LIB_CLOCK_GETTIME) $(LIB_FDATASYNC)
+# gnulib-tool also recommends $(LIB_MBRTOWC) and $(LIBINTL), but
+# modules needing those libraries are avoided so the libraries can be omitted.
if IBM_Z_DFLTCC
gzip_SOURCES += dfltcc.c
endif