summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBen Gamari <ben@smart-cactus.org>2022-04-27 15:10:05 -0400
committerMarge Bot <ben+marge-bot@smart-cactus.org>2022-05-17 00:25:02 -0400
commit0ef249aa26f653677c5368bb51af34f7577ba5b9 (patch)
tree733ab2de3d9a974e555b4034c513ab58c009e68a /configure.ac
parent43628ed44b063e25e6d1394314ed89f07f026503 (diff)
downloadhaskell-0ef249aa26f653677c5368bb51af34f7577ba5b9.tar.gz
Introduce package to capture dependency on C++ stdlib
Here we introduce a new "virtual" package into the initial package database, `system-cxx-std-lib`. This gives users a convenient, platform agnostic way to link against C++ libraries, addressing #20010. Fixes #20010.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f9e64c3383..9f673ba2d8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -692,6 +692,10 @@ AC_SUBST(CONF_HC_OPTS_STAGE0)
AC_SUBST(CONF_HC_OPTS_STAGE1)
AC_SUBST(CONF_HC_OPTS_STAGE2)
+dnl Identify C++ standard library flavour and location
+FP_FIND_CXX_STD_LIB
+AC_CONFIG_FILES([mk/system-cxx-std-lib-1.0.conf])
+
dnl ** Set up the variables for the platform in the settings file.
dnl May need to use gcc to find platform details.
dnl --------------------------------------------------------------