summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBen Gamari <ben@smart-cactus.org>2022-12-15 17:05:46 -0500
committerMarge Bot <ben+marge-bot@smart-cactus.org>2022-12-20 21:15:57 -0500
commit36c5d98e54c5ab9ede8c06f4501ed1ac83069f90 (patch)
treea019cfe8d17437dcf088bedaad8f1314f12e1f8b /configure.ac
parent7c6de18dd3151ead954c210336728e8686c91de6 (diff)
downloadhaskell-36c5d98e54c5ab9ede8c06f4501ed1ac83069f90.tar.gz
configure: Use AS_HELP_STRING instead of AC_HELP_STRING
The latter has been deprecated. See #22566.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 19daf7fa0a..c035fa70ef 100644
--- a/configure.ac
+++ b/configure.ac
@@ -143,7 +143,7 @@ if test "$EnableDistroToolchain" = "YES"; then
fi
AC_ARG_ENABLE(asserts-all-ways,
-[AC_HELP_STRING([--enable-asserts-all-ways],
+[AS_HELP_STRING([--enable-asserts-all-ways],
[Usually ASSERTs are only compiled in the DEBUG way,
this will enable them in all ways.])],
[FP_CAPITALIZE_YES_NO(["$enableval"], [EnableAssertsAllWays])],