summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBen Gamari <ben@smart-cactus.org>2022-03-29 12:27:20 -0400
committerMarge Bot <ben+marge-bot@smart-cactus.org>2022-04-25 10:19:29 -0400
commit41cf758b3f50554e0aa5240a5898b693758d9670 (patch)
tree36612cb3a1ddc44536edbe03d203ec11103f3dd5 /configure.ac
parent9420d26b4b9dd42238d3ec2a92abe0552d37775e (diff)
downloadhaskell-41cf758b3f50554e0aa5240a5898b693758d9670.tar.gz
Drop remaining vestiges of libtool
Drop libtool logic from gen-dll, allowing us to drop the remaining logic from the `configure` script. Strangely, this appears to reliably reduce compiler allocations of T16875 on Windows. Closes #18826. Metric Decrease: T16875
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 0 insertions, 17 deletions
diff --git a/configure.ac b/configure.ac
index 7f2fb42bc6..6b41a7e392 100644
--- a/configure.ac
+++ b/configure.ac
@@ -547,22 +547,6 @@ AC_CHECK_TARGET_TOOL([STRIP], [strip])
StripCmd="$STRIP"
AC_SUBST([StripCmd])
-
-dnl ** which libtool to use?
-dnl --------------------------------------------------------------
-# The host normalization on Windows breaks autoconf, it no longer
-# thinks that target == host so it never checks the unqualified
-# tools for Windows. See #14274.
-if test "$HostOS" = "mingw32"
-then
- AC_PATH_PROG([LIBTOOL],[libtool])
- LibtoolCmd="$(cygpath -m $LIBTOOL)"
-else
- AC_CHECK_TARGET_TOOL([LIBTOOL], [libtool])
- LibtoolCmd="$LIBTOOL"
-fi
-AC_SUBST([LibtoolCmd])
-
dnl ** Which otool to use on macOS
dnl --------------------------------------------------------------
AC_CHECK_TARGET_TOOL([OTOOL], [otool])
@@ -1299,7 +1283,6 @@ echo "\
ar : $ArCmd
ld : $LdCmd
nm : $NmCmd
- libtool : $LibtoolCmd
objdump : $ObjdumpCmd
ranlib : $RanlibCmd
otool : $OtoolCmd