summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorsheaf <sam.derbyshire@gmail.com>2022-09-16 12:54:09 +0200
committerMarge Bot <ben+marge-bot@smart-cactus.org>2022-09-20 03:50:06 -0400
commit545ff490144ed3ddd596d2a0c01b0a16b5528f63 (patch)
tree4e6061e82dcadda09e8eb43914b4e32cb1ad400b /configure.ac
parent19f45a25f4b14fff081d75f506e7992c81371fc5 (diff)
downloadhaskell-545ff490144ed3ddd596d2a0c01b0a16b5528f63.tar.gz
Hadrian: merge archives even in stage 0
We now always merge .a archives when ar supports -L. This change is necessary in order to bootstrap GHC using GHC 9.4 on Windows, as nested archives aren't supported. Not doing so triggered bug #21990 when trying to use the Win32 package, with errors such as: Not a x86_64 PE+ file. Unknown COFF 4 type in getHeaderInfo. ld.lld: error: undefined symbol: Win32zm2zi12zi0zi0_SystemziWin32ziConsoleziCtrlHandler_withConsoleCtrlHandler1_info We have to be careful about which ar is meant: in stage 0, the check should be done on the system ar (system-ar in system.config).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e7fce23eec..f4c66de811 100644
--- a/configure.ac
+++ b/configure.ac
@@ -201,6 +201,7 @@ if test "$WithGhc" != ""; then
fi
BOOTSTRAPPING_GHC_INFO_FIELD([AR_OPTS_STAGE0],[ar flags])
BOOTSTRAPPING_GHC_INFO_FIELD([ArSupportsAtFile_STAGE0],[ar supports at file])
+ BOOTSTRAPPING_GHC_INFO_FIELD([ArSupportsDashL_STAGE0],[ar supports -L])
BOOTSTRAPPING_GHC_INFO_FIELD([SUPPORT_SMP_STAGE0],[Support SMP])
BOOTSTRAPPING_GHC_INFO_FIELD([RTS_WAYS_STAGE0],[RTS ways])