summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAustin Seipp <aseipp@pobox.com>2013-02-10 02:24:28 -0600
committerAustin Seipp <aseipp@pobox.com>2013-02-10 02:39:28 -0600
commit61e8d5df26522b01922bc5358b9c233de0d1fc29 (patch)
tree031f515a0e3bc2ba682598a699cf7f3a6e6ccb4b /configure.ac
parentae06df63bef37c688b135ae9df3dcc1998375042 (diff)
downloadhaskell-61e8d5df26522b01922bc5358b9c233de0d1fc29.tar.gz
Better detection of clang in ./configure. Issue #7678.
Signed-off-by: Austin Seipp <aseipp@pobox.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c27b49fd38..fa01e88713 100644
--- a/configure.ac
+++ b/configure.ac
@@ -986,8 +986,14 @@ echo ["\
"]
fi
+if test "$CC_CLANG_BACKEND" = "1"; then
+CNAME="clang "
+else
+CNAME="gcc "
+fi
+
echo ["\
- Using GCC : $WhatGccIsCalled
+ Using $CNAME : $WhatGccIsCalled
which is version : $GccVersion
Building a cross compiler : $CrossCompiling