summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthew Pickering <matthewtpickering@gmail.com>2023-01-09 18:36:15 +0800
committerMarge Bot <ben+marge-bot@smart-cactus.org>2023-01-09 21:11:03 -0500
commit64286132cc0db4e227637887f98f5a3ecf7d326a (patch)
tree5cae9445f8876de69f858de4acff92a5fce39f9e /configure.ac
parentcfaf1ad7d4f75fc3f04090a17cc675d0e54e8e55 (diff)
downloadhaskell-64286132cc0db4e227637887f98f5a3ecf7d326a.tar.gz
Store bootstrap_llvm_target and use it to set LlvmTarget in bindists
This mirrors some existing logic for the bootstrap_target which influences how TargetPlatform is set. As described on #21970 not storing this led to `LlvmTarget` being set incorrectly and hence the wrong `--target` flag being passed to the C compiler. Towards #21970
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6c4b6b6f53..9b4dc0b650 100644
--- a/configure.ac
+++ b/configure.ac
@@ -667,6 +667,8 @@ GHC_LLVM_TARGET_SET_VAR
# we intend to pass trough --targets to llvm as is.
LLVMTarget_CPP=` echo "$LlvmTarget"`
AC_SUBST(LLVMTarget_CPP)
+# The target is substituted into the distrib/configure.ac file
+AC_SUBST(LlvmTarget)
dnl ** See whether cc supports --target=<triple> and set
dnl CONF_CC_OPTS_STAGE[012] accordingly.