summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSylvain Henry <sylvain@haskus.fr>2023-02-02 16:01:56 +0100
committerMarge Bot <ben+marge-bot@smart-cactus.org>2023-02-06 09:43:21 -0500
commit6636b670233522f01d002c9b97827d00289dbf5c (patch)
treeccfd2ae729261fdb52e97dec8629a875b58e4512 /configure.ac
parentb18fbf52f98d0128c52b3a90ddca727a6d5d4d45 (diff)
downloadhaskell-6636b670233522f01d002c9b97827d00289dbf5c.tar.gz
JS: replace "js" architecture with "javascript"
Despite Cabal supporting any architecture name, `cabal --check` only supports a few built-in ones. Sadly `cabal --check` is used by Hackage hence using any non built-in name in a package (e.g. `arch(js)`) is rejected and the package is prevented from being uploaded on Hackage. Luckily built-in support for the `javascript` architecture was added for GHCJS a while ago. In order to allow newer `base` to be uploaded on Hackage we make the switch from `js` to `javascript` architecture. Fixes #22740. Co-authored-by: Ben Gamari <ben@smart-cactus.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 6d04d6f207..99a91e42d6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -333,7 +333,7 @@ AC_SUBST(TablesNextToCode)
dnl ** Does target have runtime linker support?
dnl --------------------------------------------------------------
case "$target" in
- powerpc64-*|powerpc64le-*|powerpc-ibm-aix*|s390x-ibm-linux|riscv64-*|wasm*|js-*|loongarch64-*)
+ powerpc64-*|powerpc64le-*|powerpc-ibm-aix*|s390x-ibm-linux|riscv64-*|wasm*|javascript-*|loongarch64-*)
TargetHasRTSLinker=NO
;;
*)