summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBen Gamari <ben@smart-cactus.org>2022-04-30 15:10:50 -0400
committerMarge Bot <ben+marge-bot@smart-cactus.org>2022-05-04 16:16:48 -0400
commit6f6627541cfa12651d7eca716ebf49848bccb425 (patch)
treed7dd2d9ed71e99123f2372359f2b3061966bcc6f /configure.ac
parent4f6370c773b01b3164592aa224d25c69c3be9930 (diff)
downloadhaskell-6f6627541cfa12651d7eca716ebf49848bccb425.tar.gz
configure: Make sphinx version check more robust
It appears that the version of sphinx shipped on CentOS 7 reports a version string of `Sphinx v1...`. Accept the `v`. (cherry picked from commit a9197a292fd4b13308dc6664c01351c7239357ed)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0fd6442d51..7f3c9a9d6d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -791,7 +791,7 @@ AC_PATH_PROG(SPHINXBUILD,sphinx-build)
AC_CACHE_CHECK([for version of sphinx-build], fp_cv_sphinx_version,
changequote(, )dnl
[if test -n "$SPHINXBUILD"; then
- fp_cv_sphinx_version=`"$SPHINXBUILD" --version 2>&1 | sed 's/.* \([0-9]\.[0-9]\.[0-9]\)/\1/' | head -n1`;
+ fp_cv_sphinx_version=`"$SPHINXBUILD" --version 2>&1 | sed -re 's/.* v?([0-9]\.[0-9]\.[0-9])/\1/' | head -n1`;
fi;
changequote([, ])dnl
])