summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2016-11-16 18:15:52 -0500
committerBen Gamari <ben@smart-cactus.org>2016-11-17 11:04:02 -0500
commit9a4983dab9893f616db1c9be551ff9112084f887 (patch)
treeee254f94eca53291c37638011a5db183db2a754a /configure.ac
parent18eb57be98cecb657febdb4d1dc45b44eff11818 (diff)
downloadhaskell-9a4983dab9893f616db1c9be551ff9112084f887.tar.gz
Pass autoconf triplets to sub-project configures
Reviewers: austin, hvr, bgamari Reviewed By: bgamari Subscribers: thomie, erikd Differential Revision: https://phabricator.haskell.org/D2713 GHC Trac Issues: #12840
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 678fa2e609..7a7e75b639 100644
--- a/configure.ac
+++ b/configure.ac
@@ -437,7 +437,11 @@ then
else
CrossCompilePrefix=""
fi
-TargetPlatformFull="${TargetPlatform}"
+# Despite its similarity in name to TargetPlatform, TargetPlatformFull is used
+# in calls to subproject configure scripts and thus must be set to the autoconf
+# triple, not the normalized GHC triple that TargetPlatform is set to.
+# It may be better to just do away with the GHC triples all together.
+TargetPlatformFull="${target}"
AC_SUBST(CrossCompiling)
AC_SUBST(CrossCompilePrefix)
AC_SUBST(TargetPlatformFull)