summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBen Gamari <ben@smart-cactus.org>2023-01-25 16:31:40 -0500
committerMarge Bot <ben+marge-bot@smart-cactus.org>2023-01-31 13:09:50 -0500
commita2d814dc84dbdcdb6c1e274b8bd7c212cc98c39e (patch)
tree45d223fce48180074f0b96e695c90cb054551caa /configure.ac
parentf83374f8649e5d8413e7ed585b0e058690c38563 (diff)
downloadhaskell-a2d814dc84dbdcdb6c1e274b8bd7c212cc98c39e.tar.gz
configure: Always create the VERSION file
Teach the `configure` script to create the `VERSION` file. This will serve as the stable interface to allow the user to determine the version number of a working tree. Fixes #22322.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9b4dc0b650..7ebdcad7ab 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1214,6 +1214,9 @@ AC_CONFIG_FILES(
distrib/configure.ac
])
+dnl Create the VERSION file, satisfying #22322.
+printf "$ProjectVersion" > VERSION
+
AC_OUTPUT
[
if test "$print_make_warning" = "true"; then