summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorstolz <unknown>2004-09-07 15:35:43 +0000
committerstolz <unknown>2004-09-07 15:35:43 +0000
commitaee886e70717e0f8c3ed3255229ab784a84f73f1 (patch)
treeb251d32e2d522fa3437943e135ac92434900e0c4 /configure.ac
parent252abd9e355fe12e8f6f1e0192542a0df6ddccac (diff)
downloadhaskell-aee886e70717e0f8c3ed3255229ab784a84f73f1.tar.gz
[project @ 2004-09-07 15:35:39 by stolz]
Add cpp-protected signals sigINFO & sigWINCH if available. (An autoconf-wizard might want to look at the bottom of configure.ac, the similarities between HAVE_SIGPOLL, HAVE_SIGINFO & HAVE_SIGWINCH can surely be factored out)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index cf21e3922e..1ec32734f5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1419,4 +1419,22 @@ we_have_sigpoll
], AC_DEFINE([HAVE_SIGPOLL], [1], [Define to 1 if you have the sigpoll() function.]) haveSIGPOLL=yes, haveSIGPOLL=no)
AC_MSG_RESULT([$haveSIGPOLL])
+AC_MSG_CHECKING([for SIGINFO])
+AC_EGREP_CPP(we_have_siginfo,
+[#include <signal.h>
+#ifdef SIGINFO
+we_have_siginfo
+#endif
+], AC_DEFINE([HAVE_SIGINFO], [1], [Define to 1 if you have the INFO-signal.]) haveSIGINFO=yes, haveSIGINFO=no)
+AC_MSG_RESULT([$haveSIGINFO])
+
+AC_MSG_CHECKING([for SIGWINCH])
+AC_EGREP_CPP(we_have_sigwinch,
+[#include <signal.h>
+#ifdef SIGWINCH
+we_have_sigwinch
+#endif
+], AC_DEFINE([HAVE_SIGWINCH], [1], [Define to 1 if you have the WINCH-signal.]) haveSIGWINCH=yes, haveSIGWINCH=no)
+AC_MSG_RESULT([$haveSIGWINCH])
+
AC_OUTPUT(mk/config.mk, echo timestamp > mk/stamp-h )