summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRodrigo Mesquita <rodrigo.m.mesquita@gmail.com>2023-05-08 16:19:11 +0100
committerMarge Bot <ben+marge-bot@smart-cactus.org>2023-05-11 04:12:07 -0400
commitc17bb82f1cc66cb819acbfc7727a6b366097a323 (patch)
tree6c06bd797e954a4a1a4c12fe00623f1362f7c597 /configure.ac
parent40c7daed0c971e58e86a8189f82f72e9213af8b6 (diff)
downloadhaskell-c17bb82f1cc66cb819acbfc7727a6b366097a323.tar.gz
Move "target has RTS linker" out of settings
We move the "target has RTS linker" information out of configure into a predicate in GHC, and remove this option from the settings file where it is unnecessary -- it's information statically known from the platform. Note that previously we would consider `powerpc`s and `s390x`s other than `powerpc-ibm-aix*` and `s390x-ibm-linux` to have an RTS linker, but the RTS linker supports neither platform. Closes #23361
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 0 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index 49b1e9683c..899a6e65a8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -330,18 +330,6 @@ if test x"$TablesNextToCode" = xYES; then
fi
AC_SUBST(TablesNextToCode)
-dnl ** Does target have runtime linker support?
-dnl --------------------------------------------------------------
-case "$target" in
- powerpc64-*|powerpc64le-*|powerpc-ibm-aix*|s390x-ibm-linux|riscv64-*|wasm*|javascript-*|loongarch64-*)
- TargetHasRTSLinker=NO
- ;;
- *)
- TargetHasRTSLinker=YES
- ;;
-esac
-AC_SUBST(TargetHasRTSLinker)
-
# Requires FPTOOLS_SET_PLATFORMS_VARS to be run first.
FP_FIND_ROOT