summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPHO <pho@cielonegro.org>2021-05-05 15:29:36 +0900
committerMarge Bot <ben+marge-bot@smart-cactus.org>2021-12-01 03:07:32 -0500
commitc7613493e637718492f03c2f9a020198244a7b18 (patch)
tree3ef38e0d76fefa6c8e199cc916a74f8d86ac4271 /configure.ac
parent9345bfeda8f463d3fc79054166cb90fe89ea3469 (diff)
downloadhaskell-c7613493e637718492f03c2f9a020198244a7b18.tar.gz
rts/ProfHeap.c: Use setlocale() on platforms where uselocale() is not available
Not all platforms have per-thread locales. NetBSD doesn't have uselocale() in particular. Using setlocale() is of course not a safe thing to do, but it would be better than no GHC at all.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 38289862b9..7b8b747b56 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1020,7 +1020,7 @@ FP_CHECK_FUNC([GetModuleFileName],
dnl ** check for more functions
dnl ** The following have been verified to be used in ghc/, but might be used somewhere else, too.
-AC_CHECK_FUNCS([getclock getrusage gettimeofday setitimer siginterrupt sysconf times ctime_r sched_setaffinity sched_getaffinity setlocale])
+AC_CHECK_FUNCS([getclock getrusage gettimeofday setitimer siginterrupt sysconf times ctime_r sched_setaffinity sched_getaffinity setlocale uselocale])
dnl ** On OS X 10.4 (at least), time.h doesn't declare ctime_r if
dnl ** _POSIX_C_SOURCE is defined