summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorIan Lynagh <ian@well-typed.com>2012-11-13 22:30:42 +0000
committerIan Lynagh <ian@well-typed.com>2012-11-13 22:30:42 +0000
commite605c3e8c1b1a643a7c11e7aa2a7f639dd890cfe (patch)
tree5373c839f585ad47ff8b43e961c1f171510e5357 /configure.ac
parentea301fa1787761291cf0a0a9e02b9ac8f2c7b18e (diff)
downloadhaskell-e605c3e8c1b1a643a7c11e7aa2a7f639dd890cfe.tar.gz
Simplify BOOTSTRAPPING_GHC_INFO_FIELD
All supported bootstrapping compilers now have --info output, so we can use that unconditionally.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 5c887f61ee..f0bc4c35ee 100644
--- a/configure.ac
+++ b/configure.ac
@@ -131,12 +131,12 @@ if test "$WithGhc" != ""; then
GhcMinVersion2=`echo "$GhcMinVersion" | sed 's/^\\(.\\)$/0\\1/'`
GhcCanonVersion="$GhcMajVersion$GhcMinVersion2"
- BOOTSTRAPPING_GHC_INFO_FIELD([OS_STAGE0],[target os],['unkown'])
- BOOTSTRAPPING_GHC_INFO_FIELD([CC_STAGE0],[C compiler command],['$(CC)'])
+ BOOTSTRAPPING_GHC_INFO_FIELD([OS_STAGE0],[target os])
+ BOOTSTRAPPING_GHC_INFO_FIELD([CC_STAGE0],[C compiler command])
if test "x$OS_STAGE0" != "xOSDarwin"; then
- BOOTSTRAPPING_GHC_INFO_FIELD([AR_STAGE0],[ar command],['$(AR)'])
- BOOTSTRAPPING_GHC_INFO_FIELD([AR_OPTS_STAGE0],[ar flags],['$(AR_OPTS)'])
- BOOTSTRAPPING_GHC_INFO_FIELD([ArSupportsAtFile_STAGE0],[ar supports at file],['$(ArSupportsAtFile)'])
+ BOOTSTRAPPING_GHC_INFO_FIELD([AR_STAGE0],[ar command])
+ BOOTSTRAPPING_GHC_INFO_FIELD([AR_OPTS_STAGE0],[ar flags])
+ BOOTSTRAPPING_GHC_INFO_FIELD([ArSupportsAtFile_STAGE0],[ar supports at file])
else
AR_STAGE0='$(AR)'
AR_OPTS_STAGE0='$(AR_OPTS)'