summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthew Pickering <matthewtpickering@gmail.com>2022-07-04 15:30:26 +0100
committerMarge Bot <ben+marge-bot@smart-cactus.org>2022-07-18 08:04:47 -0400
commiteb031a5b913ccd645c596abe3d8630602e7c47bc (patch)
tree4c715dafbbcc75265afd7f105284e267660fe5dc /configure.ac
parentb27c5947ed9537f8cde153be4e53d4095ecbe247 (diff)
downloadhaskell-eb031a5b913ccd645c596abe3d8630602e7c47bc.tar.gz
hadrian: Add multi:<pkg> and multi targets for starting a multi-repl
This patch adds support to hadrian for starting a multi-repl containing all the packages which stage0 can build. In particular, there is the new user-facing command: ``` ./hadrian/ghci-multi ``` which when executed will start a multi-repl containing the `ghc` package and all it's dependencies. This is implemented by two new hadrian targets: ``` ./hadrian/build multi:<pkg> ``` Construct the arguments for a multi-repl session where the top-level package is <pkg>. For example, `./hadrian/ghci-multi` is implemented using `multi:ghc` target. There is also the `multi` command which constructs a repl for everything in stage0 which we can build.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e6c9ed6ec7..71b5f680cf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1179,7 +1179,7 @@ fi
# Create the configuration for the Hadrian build system if it is present
if test -e hadrian/cfg/system.config.in; then
AC_CONFIG_FILES([hadrian/cfg/system.config])
- AC_CONFIG_FILES([hadrian/ghci-cabal hadrian/ghci-stack])
+ AC_CONFIG_FILES([hadrian/ghci-cabal hadrian/ghci-stack hadrian/ghci-multi-cabal])
fi
# We got caught by