summaryrefslogtreecommitdiff
path: root/libraries/base/configure.ac
diff options
context:
space:
mode:
authorIan Lynagh <igloo@earth.li>2009-06-15 20:32:40 +0000
committerIan Lynagh <igloo@earth.li>2009-06-15 20:32:40 +0000
commit28d1321307d4d5357a792edc75d5d58a5e1ebd37 (patch)
tree82696927d8269ff2d397a69d7498eac5fc71d9c0 /libraries/base/configure.ac
parentbba3952f82832bdd95ba38dfba069ce002a4083b (diff)
downloadhaskell-28d1321307d4d5357a792edc75d5d58a5e1ebd37.tar.gz
Remove AC_C_CONST
It was breaking the build on Windows. The problem was that we included stdio.h which gave a prototype for some functions (e.g. remove), then the AC_C_CONST meant that we did /* Define to empty if `const' does not conform to ANSI C. */ #define const /**/ and then we included io.h which gave prototypes that, due to const being removed, conflicted with the earlier prototypes.
Diffstat (limited to 'libraries/base/configure.ac')
-rw-r--r--libraries/base/configure.ac3
1 files changed, 0 insertions, 3 deletions
diff --git a/libraries/base/configure.ac b/libraries/base/configure.ac
index c261c05a05..4ae0be1cb5 100644
--- a/libraries/base/configure.ac
+++ b/libraries/base/configure.ac
@@ -13,9 +13,6 @@ AC_PROG_CC()
# do we have long longs?
AC_CHECK_TYPES([long long])
-dnl ** determine whether or not const works
-AC_C_CONST
-
dnl ** check for full ANSI header (.h) files
AC_HEADER_STDC