summaryrefslogtreecommitdiff
path: root/libraries/base/configure.ac
diff options
context:
space:
mode:
authorHerbert Valerio Riedel <hvr@gnu.org>2015-12-04 09:15:29 +0100
committerHerbert Valerio Riedel <hvr@gnu.org>2015-12-04 10:01:52 +0100
commit7af29da05d2e5a5e311a5f73f20d0f232035973b (patch)
treef37df9bb14fa7baccf3c017fe61e1e267fad8420 /libraries/base/configure.ac
parent99d01e1d82505e168224043d10e7ce116f5617ae (diff)
downloadhaskell-7af29da05d2e5a5e311a5f73f20d0f232035973b.tar.gz
Use Autoconf's AC_USE_SYSTEM_EXTENSIONS
This takes care of setting feature test macros (i.e. let Autoconf decide when those can be set safely) to allow subsequent Autoconf tests to better detect available OS features. This also includes a submodule update of unix which enables the use of `AC_USE_SYSTEM_EXTENSIONS` in there as well. Specifically, this takes care of setting `_GNU_SOURCE` (which allows to remove two occurences where it's set manually) and `_ALL_SOURCE` (which fixes issues on AIX). See also https://www.gnu.org/software/autoconf/manual/autoconf-2.69/html_node/Posix-Variants.html for details. At some point we may want to reconsider the purpose of "rts/PosixSource.h" and rely more on Autoconf instead.
Diffstat (limited to 'libraries/base/configure.ac')
-rw-r--r--libraries/base/configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/libraries/base/configure.ac b/libraries/base/configure.ac
index 85b2f2e860..99474a63a7 100644
--- a/libraries/base/configure.ac
+++ b/libraries/base/configure.ac
@@ -3,6 +3,11 @@ AC_INIT([Haskell base package], [1.0], [libraries@haskell.org], [base])
# Safety check: Ensure that we are in the correct source directory.
AC_CONFIG_SRCDIR([include/HsBase.h])
+AC_PREREQ([2.60])
+
+dnl make extensions visible to allow feature-tests to detect them lateron
+AC_USE_SYSTEM_EXTENSIONS
+
AC_CONFIG_HEADERS([include/HsBaseConfig.h include/EventConfig.h])
AC_CANONICAL_BUILD