summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorfujiwarat <takao.fujiwara1@gmail.com>2016-01-20 16:42:59 +0900
committerfujiwarat <takao.fujiwara1@gmail.com>2016-01-20 16:45:28 +0900
commit99ac82ee10d4845c5a5805e0d3272710a6417488 (patch)
tree3bea4ac967c9305baf2c8bd7714d9e2fd65b777f /Makefile.am
parentaaaec9a4cc532ab35e7500785f226baf166c7380 (diff)
downloadibus-anthy-99ac82ee10d4845c5a5805e0d3272710a6417488.tar.gz
Release 1.5.81.5.8
Updated URL in anthy.appdata.xml.in Fixed bytes to str in thumb.py for python3 Fixed get_xkb_layout in thumb.py setup: Delete a check button "Show input mode icon" Implement "Automatically commit" with periods. Updated emoji.t Fixed PyGIWarning: GdkX11 was imported without specifying a version Added Variation Sector in emoji.t Split emoji.t into emoji-each.t and emoji-emoji.t
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 54dab96..7b2133b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,8 +3,8 @@
# ibus-anthy - The Anthy engine for IBus
#
# Copyright (c) 2007-2008 Peng Huang <shawn.p.huang@gmail.com>
-# Copyright (c) 2010-2013 Takao Fujiwara <takao.fujiwara1@gmail.com>
-# Copyright (c) 2007-2013 Red Hat, Inc.
+# Copyright (c) 2010-2016 Takao Fujiwara <takao.fujiwara1@gmail.com>
+# Copyright (c) 2007-2016 Red Hat, Inc.
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -49,6 +49,14 @@ DISTCLEANFILES = \
dist-hook:
if test -d .git ; then \
git log --name-status --date=iso > $(distdir)/ChangeLog ; \
+ PREV_MICRO_VERSION=`expr $(PACKAGE_VERSION_MICRO) - 1`; \
+ PREV_VERSION=\
+"$(PACKAGE_VERSION_MAJOR).$(PACKAGE_VERSION_MINOR).$$PREV_MICRO_VERSION"; \
+ echo "Changes in $(PACKAGE_NAME) $(PACKAGE_VERSION)" \
+ > $(distdir)/NEWS; \
+ echo "" >> $(distdir)/NEWS; \
+ git log $$PREV_VERSION...$(PACKAGE_VERSION) --reverse \
+ --pretty=format:'%s (%an) %h' >> $(distdir)/NEWS; \
fi
rpm: dist @PACKAGE_NAME@.spec