summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2007-05-17 12:59:51 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2007-05-17 12:59:51 -0700
commit2afbb4393b1053fcb2edbec7c92575245efabffe (patch)
tree4d8ed4c2c17bcd9c6c0489d04afb9f0f76d6a2be /Makefile.am
parent0022cf7baf11bccea0024d0dc8c1ecc37e46ef3d (diff)
downloadiceauth-2afbb4393b1053fcb2edbec7c92575245efabffe.tar.gz
Replace static ChangeLog with disthook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 5afcbd5..b1838be 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -37,9 +37,18 @@ appmandir = $(APP_MAN_DIR)
appman_DATA = $(appman_PRE:man=@APP_MAN_SUFFIX@)
-EXTRA_DIST = $(appman_PRE)
+EXTRA_DIST = $(appman_PRE) ChangeLog autogen.sh
CLEANFILES = $(appman_DATA)
+MAINTAINERCLEANFILES=ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog
+
SED = sed
# Strings to replace in man pages