summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRodney Dawes <dobey@gnome.org>2009-04-26 15:15:06 -0400
committerRodney Dawes <dobey@gnome.org>2009-04-26 15:15:06 -0400
commit2c5bbc79bc554238be6612a6ce50f07af36b0450 (patch)
treed959621c776f83d1dfff87d98dddbe281d400f81 /configure.ac
parent042c82a3a7bafc968b4f5c7d11abb4ca21ede4b7 (diff)
downloadintltool-2c5bbc79bc554238be6612a6ce50f07af36b0450.tar.gz
Rename configure.in to the preferred configure.ac
Update configure script to require new autoconf Remove the old/broken spec file Remove ChangeLog, NEWS, and MAINTAINERS as they are no longer needed Upgrade bzr branch format to 1.9
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac43
1 files changed, 43 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..6c0f5e8
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,43 @@
+dnl Process this file with autoconf to create configure.
+AC_PREREQ([2.53])
+
+AC_INIT([intltool], [0.40.6])
+AC_CONFIG_SRCDIR([intltoolize.in])
+
+AM_INIT_AUTOMAKE([foreign])
+
+pkgdatadir='${datadir}'"/${PACKAGE}"
+AC_SUBST(pkgdatadir) dnl automake does not need this, but libtoolize does
+aclocaldir='${datadir}'/aclocal
+AC_SUBST(aclocaldir)
+
+AC_PATH_PROG(PERL, perl)
+if test -z "$PERL"; then
+ AC_MSG_ERROR([perl not found])
+fi
+AC_MSG_CHECKING([for perl >= 5.8.1])
+$PERL -e "use 5.8.1;" > /dev/null 2>&1
+if test $? -ne 0; then
+ AC_MSG_ERROR([perl 5.8.1 is required for intltool])
+else
+ PERL_VERSION="`$PERL -e \"printf '%vd', $^V\"`"
+ AC_MSG_RESULT([$PERL_VERSION])
+fi
+AC_MSG_CHECKING([for XML::Parser])
+if `$PERL -e "require XML::Parser" 2>/dev/null`; then
+ AC_MSG_RESULT([ok])
+else
+ AC_MSG_ERROR([XML::Parser perl module is required for intltool])
+fi
+
+AC_CONFIG_FILES([
+Makefile
+doc/Makefile
+intltoolize
+tests/Makefile
+tests/cases/Makefile
+tests/results/Makefile
+tests/selftest.pl
+])
+
+AC_OUTPUT