summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorFrancis Dupont <fdupont@isc.org>2016-10-01 00:12:07 +0200
committerFrancis Dupont <fdupont@isc.org>2016-10-01 00:12:07 +0200
commit6831578226aa308f2d90c10c1c5a41870e085ec6 (patch)
tree62a82055c430aa9ed215664b4cd32010050cbaed /Makefile.am
parenta1372bbec77052d550678db54ee2c10721480177 (diff)
downloadisc-dhcp-6831578226aa308f2d90c10c1c5a41870e085ec6.tar.gz
Solved the --with-libbind vs distchek issue
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 5342d649..caea8833 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -23,9 +23,14 @@ EXTRA_DIST = RELNOTES LICENSE \
doc/devel/arch.dox doc/devel/atf.dox doc/devel/contrib.dox \
doc/devel/debug.dox doc/devel/isc-logo.jpg doc/devel/mainpage.dox \
doc/devel/omapi.dox doc/devel/qa.dox \
- bind/Makefile.in bind/bind.tar.gz bind/version.tmp \
common/tests/Atffile server/tests/Atffile
+if HAVE_BINDDIR
+EXTRA_DIST += bind/Makefile.in bind/bind.tar.gz bind/version.tmp
+endif
+
+# Use an autoconf substitution vs an automake conditional here
+# to fool automake when the bind directory does not exist.
SUBDIRS = @BINDSUBDIR@ includes tests common omapip client dhcpctl relay server
nobase_include_HEADERS = dhcpctl/dhcpctl.h
@@ -34,10 +39,13 @@ nobase_include_HEADERS = dhcpctl/dhcpctl.h
# distcheck tuning
#
-DISTCHECK_CONFIGURE_FLAGS = @DISTCHECK_ATF_CONFIGURE_FLAG@
+DISTCHECK_CONFIGURE_FLAGS = @DISTCHECK_ATF_CONFIGURE_FLAG@
+DISTCHECK_CONFIGURE_FLAGS += @DISTCHECK_LIBBIND_CONFIGURE_FLAG@
distcheck-hook:
+if HAVE_BINDDIR
chmod u+w $(distdir)/bind
+endif
distclean-local:
rm -f config.report