summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorShane Kerr <shane@isc.org>2007-11-16 11:04:12 +0000
committerShane Kerr <shane@isc.org>2007-11-16 11:04:12 +0000
commit6e999c3c8a96354e088da8a5a35c9ab92f419ec7 (patch)
tree375ea7f6ca88c7732d4e675d2d52b3f3693e21ec /Makefile.am
parentb9ced0286885a375857acb742091a10a787b07c7 (diff)
downloadisc-dhcp-6e999c3c8a96354e088da8a5a35c9ab92f419ec7.tar.gz
Unit test framework now added.
See RT ticket #17223 for more.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am30
1 files changed, 2 insertions, 28 deletions
diff --git a/Makefile.am b/Makefile.am
index be2f91c7..b97492e7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -15,35 +15,9 @@ EXTRA_DIST = RELNOTES \
doc/References.txt doc/References.xml doc/api+protocol \
doc/ja_JP.eucJP/dhclient-script.8 doc/ja_JP.eucJP/dhclient.8 \
doc/ja_JP.eucJP/dhclient.conf.5 doc/ja_JP.eucJP/dhclient.leases.5 \
- doc/ja_JP.eucJP/dhcp-eval.5 doc/ja_JP.eucJP/dhcp-options.5 \
- tests/failover/dhcp-1.cf tests/failover/dhcp-2.cf \
- tests/failover/new-failover \
- tests/DHCPv6/000-badmsgtype.pl \
- tests/DHCPv6/010-solicit-noclientid.pl \
- tests/DHCPv6/011-solicit-serverid.pl \
- tests/DHCPv6/020-advertise-mcast.pl \
- tests/DHCPv6/030-request-noclientid.pl \
- tests/DHCPv6/031-request-noserverid.pl \
- tests/DHCPv6/032-request-badduid.pl \
- tests/DHCPv6/110-information-request-ia_na.pl \
- tests/DHCPv6/111-information-request-ia_ta.pl \
- tests/DHCPv6/112-badduid.pl \
- tests/DHCPv6/210-solicit-nohost.pl \
- tests/DHCPv6/211-solicit-opt-in-na.pl \
- tests/DHCPv6/212-solicit-opt-in-na-norapidcommit.pl \
- tests/DHCPv6/280-release-nohost.pl \
- tests/DHCPv6/281-release-bad-address.pl \
- tests/DHCPv6/282-release-no-address.pl \
- tests/DHCPv6/283-release.pl \
- tests/DHCPv6/290-decline-nohost.pl \
- tests/DHCPv6/291-decline-bad-address.pl \
- tests/DHCPv6/292-decline-no-address.pl \
- tests/DHCPv6/293-decline.pl \
- tests/DHCPv6/README tests/DHCPv6/dhcp_client.pm \
- tests/DHCPv6/stubcli-opt-in-na.pl tests/DHCPv6/stubcli.pl \
- tests/DHCPv6/test-a.conf tests/DHCPv6/test-b.conf
+ doc/ja_JP.eucJP/dhcp-eval.5 doc/ja_JP.eucJP/dhcp-options.5
-SUBDIRS = includes common minires dst omapip client dhcpctl relay server
+SUBDIRS = includes tests common minires dst omapip client dhcpctl relay server
nobase_include_HEADERS = dhcpctl/dhcpctl.h