summaryrefslogtreecommitdiff
path: root/client/Makefile.am
diff options
context:
space:
mode:
authorShawn Routhier <sar@isc.org>2014-05-16 15:24:48 -0700
committerShawn Routhier <sar@isc.org>2014-05-16 15:24:48 -0700
commit79818c93448403843280bcb9b3d33f70461828c7 (patch)
tree215d4b43dade7f0a837c2a783bb84622f854310f /client/Makefile.am
parent63c8800c3cb7adafde12d56cfa4c599907dc516c (diff)
downloadisc-dhcp-79818c93448403843280bcb9b3d33f70461828c7.tar.gz
[master] Add -df option to client code to help share DUIDs
Add the "-df <duid file>" option to the client code in order to make it easier to share DUIDs between a v4 instance and a v6 instance. This option instructs the client to search the duid file for a DUID if it didn't find one in the main lease file. In addition add the infrastructure for running ATF tests for the client and write some ATF tests for this patch.
Diffstat (limited to 'client/Makefile.am')
-rw-r--r--client/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/client/Makefile.am b/client/Makefile.am
index 59364aa0..85645af8 100644
--- a/client/Makefile.am
+++ b/client/Makefile.am
@@ -1,3 +1,9 @@
+# We want to build this directory first, before descending into tests subdir.
+# The reason is that ideally the tests should link existing objects from this
+# directory. That eliminates any discrepancies between tested code and
+# production code. Sadly, we are not there yet.
+SUBDIRS = . tests
+
dist_sysconf_DATA = dhclient.conf.example
sbin_PROGRAMS = dhclient
dhclient_SOURCES = clparse.c dhclient.c dhc6.c \