summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFrancis Dupont <fdupont@isc.org>2016-10-06 10:23:24 +0200
committerFrancis Dupont <fdupont@isc.org>2016-10-06 10:23:24 +0200
commit3a4fc3841ea817c848e5a231b9e5c8f5c9895e6d (patch)
tree7d6ad981129b4cd8f4b765a2110ac13889d24ebd /configure.ac
parenta1eea2a0d14c25d395d45ffb215df3d81a5b1da1 (diff)
parent5a67b030872447c8bd845b41a77404ec0438fb33 (diff)
downloadisc-dhcp-3a4fc3841ea817c848e5a231b9e5c8f5c9895e6d.tar.gz
Finished merge of rt39318 (install embedded bind9 includes and libs)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index eb2a28a2..7f199a84 100644
--- a/configure.ac
+++ b/configure.ac
@@ -798,6 +798,13 @@ AC_SUBST(BINDLIBISCDIR)
AC_SUBST(DISTCHECK_LIBBIND_CONFIGURE_FLAG)
AM_CONDITIONAL(HAVE_BINDDIR, test "$use_libbind" = "no")
+AC_ARG_ENABLE(bind_install,
+ AS_HELP_STRING([--enable-bind-install],[install bind includes and libraries (default is no).]))
+if test "$enable_bind_install" = "yes" -a "$use_libbind" != "no"; then
+ AC_MSG_WARN([--enable-bind-install does nothing when --with-libbind is set])
+fi
+AM_CONDITIONAL(INSTALL_BIND, test "$enable_bind_install" = "yes")
+
# OpenLDAP support.
AC_ARG_WITH(ldap,
AS_HELP_STRING([--with-ldap],[enable OpenLDAP support in dhcpd (default is no)]),