summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFrancis Dupont <fdupont@isc.org>2016-10-01 00:12:07 +0200
committerFrancis Dupont <fdupont@isc.org>2016-10-01 00:12:07 +0200
commit6831578226aa308f2d90c10c1c5a41870e085ec6 (patch)
tree62a82055c430aa9ed215664b4cd32010050cbaed /configure.ac
parenta1372bbec77052d550678db54ee2c10721480177 (diff)
downloadisc-dhcp-6831578226aa308f2d90c10c1c5a41870e085ec6.tar.gz
Solved the --with-libbind vs distchek issue
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 46d56275..94cde26d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -738,6 +738,7 @@ BINDLIBIRSDIR=
BINDLIBDNSDIR=
BINDLIBISCCFGDIR=
BINDLIBISCDIR=
+DISTCHECK_LIBBIND_CONFIGURE_FLAG=
AC_ARG_WITH(libbind,
AS_HELP_STRING([--with-libbind=PATH],[bind includes and libraries are in PATH]),
use_libbind="$withval", use_libbind="no")
@@ -784,6 +785,7 @@ no)
BINDLIBDNSDIR="$BINDDIR/lib"
BINDLIBISCCFGDIR="$BINDDIR/lib"
BINDLIBISCDIR="$BINDDIR/lib"
+ DISTCHECK_LIBBIND_CONFIGURE_FLAG="--with-libbind=$use_libbind"
;;
esac
AC_SUBST(BINDSUBDIR)
@@ -793,6 +795,8 @@ AC_SUBST(BINDLIBIRSDIR)
AC_SUBST(BINDLIBDNSDIR)
AC_SUBST(BINDLIBISCCFGDIR)
AC_SUBST(BINDLIBISCDIR)
+AC_SUBST(DISTCHECK_LIBBIND_CONFIGURE_FLAG)
+AM_CONDITIONAL(HAVE_BINDDIR, test "$use_libbind" = "no")
# OpenLDAP support.
AC_ARG_WITH(ldap,