summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFrancis Dupont <fdupont@isc.org>2016-02-23 10:40:10 +0100
committerFrancis Dupont <fdupont@isc.org>2016-02-23 10:40:10 +0100
commit785c1a519e88bfebb70bd3384589de36bee02dd2 (patch)
tree04f794b247068983b2df432fb20f229de1e8bf03 /configure.ac
parent08ad1e3c9089b51888c73837cf41de49112de29c (diff)
downloadisc-dhcp-785c1a519e88bfebb70bd3384589de36bee02dd2.tar.gz
Merged rt35711c (DHCPv4-over-DHCPv6 support)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 27 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9351150a..7f05b7d6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -149,6 +149,23 @@ if test "$enable_dhcpv6" != "no"; then
[Define to 1 to include DHCPv6 support.])
fi
+# DHCPv4o6 optional compile-time feature.
+AC_ARG_ENABLE(dhcpv4o6,
+ AS_HELP_STRING([--enable-dhcpv4o6],[enable support for DHCPv4-over-DHCPv6 (default is no)]))
+# DHCPv4o6 is off by default, so define if it is explicitly enabled.
+if test "$enable_dhcpv4o6" = "yes"; then
+ # DHCPv4o6 requires DHCPv6
+ if test "$enable_dhcpv6" = "no"; then
+ AC_MSG_ERROR([dhcpv4o6 requires dhcpv6])
+ fi
+ # DHCPv4o6 is not yet compatible with delayed-ack
+ if test "$enable_delayed_ack" = "yes"; then
+ AC_MSG_ERROR([dhcpv4o6 is not compatible with delayed-ack])
+ fi
+ AC_DEFINE([DHCP4o6], [1],
+ [Define to 1 to include DHCPv4 over DHCPv6 support.])
+fi
+
# PARANOIA is off by default (until we can test it with all features)
AC_ARG_ENABLE(paranoia,
AS_HELP_STRING([--enable-paranoia],[enable support for chroot/setuid (default is no)]))
@@ -799,6 +816,14 @@ AC_CONFIG_FILES([
])
AC_OUTPUT
+if test "$enable_dhcpv4o6" = "yes"; then
+ DHCP_VERSIONS="DHCPv4, DHCPv6 and DHCPv4-over-DHCPv6"
+elif test "$enable_dhcpv6" != "no"; then
+ DHCP_VERSIONS="DHCPv4 and DHCPv6"
+else
+ DHCP_VERSIONS="DHCPv4"
+fi
+
(cd $srcdir
sh util/bindvar.sh
if test $? -ne 0; then
@@ -821,6 +846,8 @@ Flags:
DEFS: $DEFS
CFLAGS: $CFLAGS
+DHCP versions: $DHCP_VERSIONS
+
Features:
debug: $enable_debug
failover: $enable_failover