summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorShawn Routhier <sar@isc.org>2011-02-18 18:41:25 +0000
committerShawn Routhier <sar@isc.org>2011-02-18 18:41:25 +0000
commit8a0d9ca4399de7119bbaf8c09f8c63b5669b5465 (patch)
tree086f8d26ea74fdabb947e14afdb6a6a64b009b4c /configure.ac
parent919f14071d9dd69d1c09321ba8f9b74ab0e75655 (diff)
downloadisc-dhcp-8a0d9ca4399de7119bbaf8c09f8c63b5669b5465.tar.gz
Some fixes for LDAP
[ISC-Bugs #21783] - Include lber library when building ldap [ISC-Bugs #22888] - Enable the ldap code when buidling common
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 76616c06..391da15e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -523,6 +523,8 @@ AC_ARG_WITH(ldapcrypto,
if test x$ldap = xyes || test x$ldapcrypto = xyes ; then
AC_SEARCH_LIBS(ldap_initialize, [ldap], ,
AC_MSG_FAILURE([*** Cannot find ldap_initialize with -lldap - do you need to install an OpenLDAP2 Devel package?]))
+ AC_SEARCH_LIBS(ber_pvt_opt_on, [lber], ,
+ AC_MSG_FAILURE([*** Cannot find ber_pvt_opt_on with -llber - do you need to install an OpenLDAP2 Devel package?]))
if test x$ldapcrypto = xyes ; then
AC_SUBST(LDAP_CFLAGS, ["-DLDAP_CONFIGURATION -DLDAP_USE_SSL"])