summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMark Andrews <marka@isc.org>2013-03-28 17:11:06 +1100
committerMark Andrews <marka@isc.org>2013-03-28 17:11:06 +1100
commita24b9f23d044a7991a5df98cc6d9c0b6882020df (patch)
tree780616285139ab98147aa928fc66a9c4ec16d09b /configure.ac
parent8e112e2bc6c2d1fd82a30bcc25f862be24d82b8b (diff)
downloadisc-dhcp-a24b9f23d044a7991a5df98cc6d9c0b6882020df.tar.gz
- Use newer auto* tool packages and turn on RFC_3542 support on Mac OS.
[ISC-Bugs #26303]
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 86f9d284..d14a0193 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11,6 +11,8 @@ AM_INIT_AUTOMAKE([foreign])
# might fail if they don't have the correct tools.
AM_MAINTAINER_MODE
+AC_CANONICAL_HOST
+
# We want to turn on warnings if we are using gcc and the user did
# not specify CFLAGS. The autoconf check for the C compiler sets the
# CFLAGS if gcc is used, so we will save it before we run that check.
@@ -637,6 +639,11 @@ CFLAGS="$CFLAGS $STD_CWARNINGS"
# Try to add the bind include directory
CFLAGS="$CFLAGS -I$libbind/include"
+case "$host" in
+*-darwin*)
+ CFLAGS="$CFLAGS -D__APPLE_USE_RFC_3542" ;;
+esac
+
AC_C_FLEXIBLE_ARRAY_MEMBER
AC_OUTPUT([