summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFrancis Dupont <fdupont@isc.org>2015-04-16 23:47:32 +0200
committerFrancis Dupont <fdupont@isc.org>2015-04-16 23:47:32 +0200
commitb4a10c76f139f8070780b71366fcc083cbb1f126 (patch)
treeaf270ad0edf4259666f5ad44d2a3562b80f8bdf5 /configure.ac
parent1b245c913a93296cd6924d81cf7f876f874b080c (diff)
downloadisc-dhcp-b4a10c76f139f8070780b71366fcc083cbb1f126.tar.gz
rebased on #39300 for HP-UX make
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9f81078d..612aeca9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -34,7 +34,11 @@ fi
# We can have some flags to pass to bind configure
BINDCONFIG=
+if test "$cross_compiling" = "yes"; then
+ BINDCONFIG="--host=$host"
+fi
AC_SUBST(BINDCONFIG)
+AM_CONDITIONAL(CROSS_COMPILING, test "$cross_compiling" = "yes")
# POSIX doesn't include the IPv6 Advanced Socket API and glibc hides
# parts of the IPv6 Advanced Socket API as a result. This is stupid