summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorShawn Routhier <sar@isc.org>2013-10-14 15:53:24 -0700
committerShawn Routhier <sar@isc.org>2013-10-14 15:53:24 -0700
commitd7d9c0c7c36d37fc42e51987af77207ced36d9bf (patch)
tree2f7b49de9f03c1097c109e425f0034accc3e7de9 /configure.ac
parent1d851cff2c59ba728cf6a862db9b1890967de317 (diff)
downloadisc-dhcp-d7d9c0c7c36d37fc42e51987af77207ced36d9bf.tar.gz
-n [master]
Add code to support the standards version of DDNS
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac124
1 files changed, 43 insertions, 81 deletions
diff --git a/configure.ac b/configure.ac
index 52928199..417b240e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-AC_INIT([DHCP], [4.3.0-Pre-Beta], [dhcp-users@isc.org])
+AC_INIT([DHCP],[4.3.0-Pre-Beta],[dhcp-users@isc.org])
# we specify "foreign" to avoid having to have the GNU mandated files,
# like AUTHORS, COPYING, and such
@@ -51,8 +51,7 @@ AC_DEFINE_UNQUOTED([DHCP_BYTE_ORDER], [$byte_order],
# Optional compile-time DEBUGging.
AC_ARG_ENABLE(debug,
- AC_HELP_STRING([--enable-debug],
- [create a debug-only version of the software (default is no).]),
+ AS_HELP_STRING([--enable-debug],[create a debug-only version of the software (default is no).]),
[enable_debug=yes],[enable_debug=no])
# This is very much off by default.
if test "$enable_debug" = "yes" ; then
@@ -83,8 +82,7 @@ fi
# Failover optional compile-time feature.
AC_ARG_ENABLE(failover,
- AC_HELP_STRING([--enable-failover],
- [enable support for failover (default is yes)]))
+ AS_HELP_STRING([--enable-failover],[enable support for failover (default is yes)]))
# Failover is on by default, so define if it is not explicitly disabled.
if test "$enable_failover" != "no"; then
AC_DEFINE([FAILOVER_PROTOCOL], [1],
@@ -93,8 +91,7 @@ fi
# execute() support.
AC_ARG_ENABLE(execute,
- AC_HELP_STRING([--enable-execute],
- [enable support for execute() in config (default is yes)]))
+ AS_HELP_STRING([--enable-execute],[enable support for execute() in config (default is yes)]))
# execute() is on by default, so define if it is not explicitly disabled.
if test "$enable_execute" != "no" ; then
AC_DEFINE([ENABLE_EXECUTE], [1],
@@ -103,8 +100,7 @@ fi
# Server tracing support.
AC_ARG_ENABLE(tracing,
- AC_HELP_STRING([--enable-tracing],
- [enable support for server activity tracing (default is yes)]))
+ AS_HELP_STRING([--enable-tracing],[enable support for server activity tracing (default is yes)]))
# tracing is on by default, so define if it is not explicitly disabled.
if test "$enable_tracing" != "no" ; then
AC_DEFINE([TRACING], [1],
@@ -113,8 +109,7 @@ fi
# Delayed-ack feature support (experimental).
AC_ARG_ENABLE(delayed_ack,
- AC_HELP_STRING([--enable-delayed-ack],
- [queues multiple DHCPACK replies (default is no)]))
+ AS_HELP_STRING([--enable-delayed-ack],[queues multiple DHCPACK replies (default is no)]))
if test "$enable_delayed_ack" = "yes"; then
AC_DEFINE([DELAYED_ACK], [1],
[Define to queue multiple DHCPACK replies per fsync.])
@@ -122,8 +117,7 @@ fi
# DHCPv6 optional compile-time feature.
AC_ARG_ENABLE(dhcpv6,
- AC_HELP_STRING([--enable-dhcpv6],
- [enable support for DHCPv6 (default is yes)]))
+ AS_HELP_STRING([--enable-dhcpv6],[enable support for DHCPv6 (default is yes)]))
# DHCPv6 is on by default, so define if it is not explicitly disabled.
if test "$enable_dhcpv6" != "no"; then
AC_DEFINE([DHCPv6], [1],
@@ -132,11 +126,9 @@ fi
# PARANOIA is off by default (until we can test it with all features)
AC_ARG_ENABLE(paranoia,
- AC_HELP_STRING([--enable-paranoia],
- [enable support for chroot/setuid (default is no)]))
+ AS_HELP_STRING([--enable-paranoia],[enable support for chroot/setuid (default is no)]))
AC_ARG_ENABLE(early_chroot,
- AC_HELP_STRING([--enable-early-chroot],
- [enable chrooting prior to configuration (default is no)]))
+ AS_HELP_STRING([--enable-early-chroot],[enable chrooting prior to configuration (default is no)]))
# If someone enables early chroot, but does not enable paranoia, do so for
# them.
if test "$enable_paranoia" != "yes" && \
@@ -154,8 +146,7 @@ if test "$enable_early_chroot" = "yes" ; then
fi
AC_ARG_ENABLE(ipv4_pktinfo,
- AC_HELP_STRING([--enable-ipv4-pktinfo],
- [enable use of pktinfo on IPv4 sockets (default is no)]))
+ AS_HELP_STRING([--enable-ipv4-pktinfo],[enable use of pktinfo on IPv4 sockets (default is no)]))
if test "$enable_ipv4_pktinfo" = "yes"; then
AC_DEFINE([USE_V4_PKTINFO], [1],
@@ -163,8 +154,7 @@ if test "$enable_ipv4_pktinfo" = "yes"; then
fi
AC_ARG_ENABLE(use_sockets,
- AC_HELP_STRING([--enable-use-sockets],
- [use the standard BSD socket API (default is no)]))
+ AS_HELP_STRING([--enable-use-sockets],[use the standard BSD socket API (default is no)]))
if test "$enable_use_sockets" = "yes"; then
AC_DEFINE([USE_SOCKETS], [1],
@@ -174,8 +164,7 @@ fi
# Try to hnadle incorrect byte order for secs field
# This is off by default
AC_ARG_ENABLE(secs_byteorder,
- AC_HELP_STRING([--enable-secs-byteorder],
- [Correct bad byteorders in the secs field (default is no).]))
+ AS_HELP_STRING([--enable-secs-byteorder],[Correct bad byteorders in the secs field (default is no).]))
if test "$enable_secs_byteorder" = "yes" ; then
AC_DEFINE([SECS_BYTEORDER], [1],
@@ -186,8 +175,7 @@ fi
atf_path="no"
AC_ARG_WITH([atf],
- AC_HELP_STRING([--with-atf=PATH],
- [specify location where atf was installed]),
+ AS_HELP_STRING([--with-atf=PATH],[specify location where atf was installed]),
[atf_path="$withval"])
if test "$atf_path" != "no" ; then
# Config path for pkg-config
@@ -245,8 +233,7 @@ esac
# Allow specification of alternate state files
AC_ARG_WITH(srv-lease-file,
- AC_HELP_STRING([--with-srv-lease-file=PATH],
- [File for dhcpd leases
+ AS_HELP_STRING([--with-srv-lease-file=PATH],[File for dhcpd leases
(default is LOCALSTATEDIR/db/dhcpd.leases)]),
AC_DEFINE_UNQUOTED([_PATH_DHCPD_DB], ["$withval"],
[File for dhcpd leases.]))
@@ -276,8 +263,7 @@ fi
echo "$with_srv_lease_file"
AC_ARG_WITH(srv6-lease-file,
- AC_HELP_STRING([--with-srv6-lease-file=PATH],
- [File for dhcpd6 leases
+ AS_HELP_STRING([--with-srv6-lease-file=PATH],[File for dhcpd6 leases
(default is LOCALSTATEDIR/db/dhcpd6.leases)]),
AC_DEFINE_UNQUOTED([_PATH_DHCPD6_DB], ["$withval"],
[File for dhcpd6 leases.]))
@@ -307,8 +293,7 @@ fi
echo "$with_srv6_lease_file"
AC_ARG_WITH(cli-lease-file,
- AC_HELP_STRING([--with-cli-lease-file=PATH],
- [File for dhclient leases
+ AS_HELP_STRING([--with-cli-lease-file=PATH],[File for dhclient leases
(default is LOCALSTATEDIR/db/dhclient.leases)]),
AC_DEFINE_UNQUOTED([_PATH_DHCLIENT_DB], ["$withval"],
[File for dhclient leases.]))
@@ -338,8 +323,7 @@ fi
echo "$with_cli_lease_file"
AC_ARG_WITH(cli6-lease-file,
- AC_HELP_STRING([--with-cli6-lease-file=PATH],
- [File for dhclient6 leases
+ AS_HELP_STRING([--with-cli6-lease-file=PATH],[File for dhclient6 leases
(default is LOCALSTATEDIR/db/dhclient6.leases)]),
AC_DEFINE_UNQUOTED([_PATH_DHCLIENT6_DB], ["$withval"],
[File for dhclient6 leases.]))
@@ -369,38 +353,32 @@ fi
echo "$with_cli6_lease_file"
AC_ARG_WITH(srv-pid-file,
- AC_HELP_STRING([--with-srv-pid-file=PATH],
- [File for dhcpd process information
+ AS_HELP_STRING([--with-srv-pid-file=PATH],[File for dhcpd process information
(default is LOCALSTATEDIR/run/dhcpd.pid)]),
AC_DEFINE_UNQUOTED([_PATH_DHCPD_PID], ["$withval"],
[File for dhcpd process information.]))
AC_ARG_WITH(srv6-pid-file,
- AC_HELP_STRING([--with-srv6-pid-file=PATH],
- [File for dhcpd6 process information
+ AS_HELP_STRING([--with-srv6-pid-file=PATH],[File for dhcpd6 process information
(default is LOCALSTATEDIR/run/dhcpd6.pid)]),
AC_DEFINE_UNQUOTED([_PATH_DHCPD6_PID], ["$withval"],
[File for dhcpd6 process information.]))
AC_ARG_WITH(cli-pid-file,
- AC_HELP_STRING([--with-cli-pid-file=PATH],
- [File for dhclient process information
+ AS_HELP_STRING([--with-cli-pid-file=PATH],[File for dhclient process information
(default is LOCALSTATEDIR/run/dhclient.pid)]),
AC_DEFINE_UNQUOTED([_PATH_DHCLIENT_PID], ["$withval"],
[File for dhclient process information.]))
AC_ARG_WITH(cli6-pid-file,
- AC_HELP_STRING([--with-cli6-pid-file=PATH],
- [File for dhclient6 process information
+ AS_HELP_STRING([--with-cli6-pid-file=PATH],[File for dhclient6 process information
(default is LOCALSTATEDIR/run/dhclient6.pid)]),
AC_DEFINE_UNQUOTED([_PATH_DHCLIENT6_PID], ["$withval"],
[File for dhclient6 process information.]))
AC_ARG_WITH(relay-pid-file,
- AC_HELP_STRING([--with-relay-pid-file=PATH],
- [File for dhcrelay process information
+ AS_HELP_STRING([--with-relay-pid-file=PATH],[File for dhcrelay process information
(default is LOCALSTATEDIR/run/dhcrelay.pid)]),
AC_DEFINE_UNQUOTED([_PATH_DHCRELAY_PID], ["$withval"],
[File for dhcrelay process information.]))
AC_ARG_WITH(relay6-pid-file,
- AC_HELP_STRING([--with-relay6-pid-file=PATH],
- [File for dhcrelay6 process information
+ AS_HELP_STRING([--with-relay6-pid-file=PATH],[File for dhcrelay6 process information
(default is LOCALSTATEDIR/run/dhcrelay6.pid)]),
AC_DEFINE_UNQUOTED([_PATH_DHCRELAY6_PID], ["$withval"],
[File for dhcrelay6 process information.]))
@@ -473,51 +451,37 @@ fi
# int value.
#
AC_MSG_CHECKING([for struct lifnum])
-AC_TRY_COMPILE(
-[ #include <sys/types.h>
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[ #include <sys/types.h>
#include <sys/socket.h>
#include <net/if.h>
-],
-[ struct lifnum a;
-],
- [AC_MSG_RESULT(yes)
+]], [[ struct lifnum a;
+]])],[AC_MSG_RESULT(yes)
AC_DEFINE([ISC_PLATFORM_HAVELIFNUM], [1],
- [Define to 1 if the system has 'struct lifnum'.])],
- [AC_MSG_RESULT(no)])
+ [Define to 1 if the system has 'struct lifnum'.])],[AC_MSG_RESULT(no)])
AC_MSG_CHECKING([for struct if_laddrconf])
-AC_TRY_COMPILE(
-[ #include <sys/types.h>
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[ #include <sys/types.h>
#include <net/if6.h>
-],
-[ struct if_laddrconf a;
-],
- [AC_MSG_RESULT(yes)
+]], [[ struct if_laddrconf a;
+]])],[AC_MSG_RESULT(yes)
AC_DEFINE([ISC_PLATFORM_HAVEIF_LADDRCONF], [1],
- [Define to 1 if the system has 'struct if_laddrconf'.])],
- [AC_MSG_RESULT(no)])
+ [Define to 1 if the system has 'struct if_laddrconf'.])],[AC_MSG_RESULT(no)])
AC_MSG_CHECKING([for struct if_laddrreq])
-AC_TRY_LINK(
-[#include <sys/types.h>
+AC_LINK_IFELSE([AC_LANG_PROGRAM([[#include <sys/types.h>
#include <net/if6.h>
-],
-[ struct if_laddrreq a;
-],
- [AC_MSG_RESULT(yes)
+]], [[ struct if_laddrreq a;
+]])],[AC_MSG_RESULT(yes)
AC_DEFINE([ISC_PLATFORM_HAVEIF_LADDRREQ], [1],
- [Define to 1 if the system has 'struct if_laddrreq'.])],
- [AC_MSG_RESULT(no)])
+ [Define to 1 if the system has 'struct if_laddrreq'.])],[AC_MSG_RESULT(no)])
#
# check for GCC noreturn attribute
#
AC_MSG_CHECKING(for GCC noreturn attribute)
-AC_TRY_COMPILE([],[void foo() __attribute__((noreturn));],
- [AC_MSG_RESULT(yes)
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]], [[void foo() __attribute__((noreturn));]])],[AC_MSG_RESULT(yes)
AC_DEFINE([ISC_DHCP_NORETURN], [__attribute__((noreturn))],
- [Define to the string for a noreturn attribute.])],
- [AC_MSG_RESULT(no)
+ [Define to the string for a noreturn attribute.])],[AC_MSG_RESULT(no)
AC_DEFINE([ISC_DHCP_NORETURN], [],
[Define to the string for a noreturn attribute.])])
@@ -588,8 +552,7 @@ AC_CHECK_MEMBER(struct msghdr.msg_control,,
libbind=
AC_ARG_WITH(libbind,
- AC_HELP_STRING([--with-libbind=PATH],
- [bind includes and libraries are in PATH
+ AS_HELP_STRING([--with-libbind=PATH],[bind includes and libraries are in PATH
(default is ./bind)]),
use_libbind="$withval", use_libbind="no")
case "$use_libbind" in
@@ -606,15 +569,13 @@ esac
# OpenLDAP support.
AC_ARG_WITH(ldap,
- AC_HELP_STRING([--with-ldap],
- [enable OpenLDAP support in dhcpd (default is no)]),
+ AS_HELP_STRING([--with-ldap],[enable OpenLDAP support in dhcpd (default is no)]),
[ldap=$withval],
[ldap=no])
# OpenLDAP with SSL support.
AC_ARG_WITH(ldapcrypto,
- AC_HELP_STRING([--with-ldapcrypto],
- [enable OpenLDAP crypto support in dhcpd (default is no)]),
+ AS_HELP_STRING([--with-ldapcrypto],[enable OpenLDAP crypto support in dhcpd (default is no)]),
[ldapcrypto=$withval],
[ldapcrypto=no])
@@ -635,7 +596,7 @@ if test x$ldap = xyes || test x$ldapcrypto = xyes ; then
fi
# Append selected warning levels to CFLAGS before substitution (but after
-# AC_TRY_COMPILE & etc).
+# AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]], [[]])],[],[]) & etc).
CFLAGS="$CFLAGS $STD_CWARNINGS"
# Try to add the bind include directory
@@ -648,7 +609,7 @@ esac
AC_C_FLEXIBLE_ARRAY_MEMBER
-AC_OUTPUT([
+AC_CONFIG_FILES([
Makefile
client/Makefile
common/Makefile
@@ -663,6 +624,7 @@ AC_OUTPUT([
server/tests/Makefile
doc/devel/doxyfile
])
+AC_OUTPUT
sh util/bindvar.sh