summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFrancis Dupont <fdupont@isc.org>2016-10-15 11:20:55 +0200
committerFrancis Dupont <fdupont@isc.org>2016-10-15 11:20:55 +0200
commitf6d4c27f49cfe5c411e6388333e7db6917a60560 (patch)
treeca7ed04e34d506a95afc498714e0a2ff5a281177 /configure.ac
parentfe1319546966cf456dc5a2cbda209636b36e37cf (diff)
downloadisc-dhcp-f6d4c27f49cfe5c411e6388333e7db6917a60560.tar.gz
Added check for nanosleep in -lrt
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7f199a84..2a1cc150 100644
--- a/configure.ac
+++ b/configure.ac
@@ -612,6 +612,16 @@ AC_CHECK_FUNCS(strlcat)
# For HP/UX we need -lipv6 for if_nametoindex, perhaps others.
AC_SEARCH_LIBS(if_nametoindex, [ipv6])
+# For some Solaris nanosleep is found by BIND in librt
+have_nanosleep="no"
+AC_CHECK_FUNC(nanosleep, have_nanosleep="yes")
+if test "$have_nanosleep" = "no"; then
+ AC_CHECK_LIB(rt, nanosleep, have_nanosleep="rt")
+fi
+if test "$have_nanosleep" = "rt"; then
+ LIBS="-lrt $LIBS"
+fi
+
# check for /dev/random (declares HAVE_DEV_RANDOM)
AC_MSG_CHECKING(for random device)
AC_ARG_WITH(randomdev,