summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFrancis Dupont <fdupont@isc.org>2016-10-05 01:42:00 +0200
committerFrancis Dupont <fdupont@isc.org>2016-10-05 01:42:00 +0200
commitf97415144ff0aa6c317c207b646f9c51756dbb12 (patch)
tree43a672655a55c5bff0206773ea002e8a676b75b6 /configure.ac
parentf9e73c1846428a8471766a09b5e49590c3aade20 (diff)
downloadisc-dhcp-f97415144ff0aa6c317c207b646f9c51756dbb12.tar.gz
Added --enable-bind-install
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 94cde26d..93864421 100644
--- a/configure.ac
+++ b/configure.ac
@@ -798,6 +798,13 @@ AC_SUBST(BINDLIBISCDIR)
AC_SUBST(DISTCHECK_LIBBIND_CONFIGURE_FLAG)
AM_CONDITIONAL(HAVE_BINDDIR, test "$use_libbind" = "no")
+AC_ARG_ENABLE(bind_install,
+ AS_HELP_STRING([--enable-bind-install],[install bind includes and libraries (default is no).]))
+if test "$enable_bind_install" = "yes" -a "$use_libbind" != "no"; then
+ AC_MSG_WARN([--enable-bind-install does nothing when --with-libbind is set])
+fi
+AM_CONDITIONAL(INSTALL_BIND, test "$enable_bind_install" = "yes")
+
# OpenLDAP support.
AC_ARG_WITH(ldap,
AS_HELP_STRING([--with-ldap],[enable OpenLDAP support in dhcpd (default is no)]),