summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTobias Quathamer <toddy@debian.org>2012-08-08 09:37:30 +0200
committerTobias Quathamer <toddy@debian.org>2012-08-08 09:37:30 +0200
commit2761d743d22a5ef41e85cfcde1600eb9d5fee8b9 (patch)
tree506fdd5d5f74eb9c0ce050ea040d4b9f3695b312 /Makefile.am
parentd8cf0cdb16fec6f3167361310fdba4f8ef582ceb (diff)
downloadiso-codes-2761d743d22a5ef41e85cfcde1600eb9d5fee8b9.tar.gz
Imported Upstream version 3.38upstream/3.38
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 6 insertions, 10 deletions
diff --git a/Makefile.am b/Makefile.am
index 1eafe15f..460ca162 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -22,18 +22,14 @@ update-po:
done
.PHONY: sign-release
-sign-release: iso-codes-$(VERSION).tar.bz2
- rm -f iso-codes-$(VERSION).tar.bz2.sig
- gpg --detach-sign iso-codes-$(VERSION).tar.bz2
+sign-release: iso-codes-$(VERSION).tar.xz
+ rm -f iso-codes-$(VERSION).tar.xz.sig
+ gpg --detach-sign iso-codes-$(VERSION).tar.xz
.PHONY: upload
upload:
- @if [[ "$(ALIOTH_USERNAME)" == "" ]]; then \
- ALIOTH_USERNAME="$(USERNAME)"; \
- fi
- @if [[ -f "iso-codes-$(VERSION).tar.bz2" ]] \
- && [[ -f "iso-codes-$(VERSION).tar.bz2.sig" ]] \
- && [[ -n "$(ALIOTH_USERNAME)" ]]; then \
+ @if [[ -f "iso-codes-$(VERSION).tar.xz" ]] \
+ && [[ -f "iso-codes-$(VERSION).tar.xz.sig" ]]; then \
scp iso-codes-$(VERSION).tar.* \
- $(ALIOTH_USERNAME)@alioth.debian.org:/srv/home/groups/pkg-isocodes/htdocs/downloads; \
+ alioth.debian.org:/srv/home/groups/pkg-isocodes/htdocs/downloads; \
fi